Multiple shapes - how to join/share cut lines

Hi -

This is probably super elementary but I’m really new to Lightburn…

I need to cut many copies of the same rectangular shape. I can use “Arrange…Grid / Array” to create a layout. I have set X and Y spacing to 0 so the shapes’ edges are coincident. How can I set things up so that when two shapes share a side, only one cut is made for that line? My primary purpose in making such an arrangement is to save cut time and cutting the coincident edges twice doesn’t make sense.

Thanks!!

Probably the best way is to do any engraving separate of the cutting. Then you can delete duplicates on the cut layer. Engraving doesn’t work with open vectors, but cutting does.

If you’re cutting squares, for instance, then I’d probably delete the left and top edges for example, and array that with a 0 gap up and right, and that should do what you want.

I’m sure it’ll be different if you’re cutting other weird shapes though. Maybe you could post a screenshot of what you’re cutting, and that would give us a better idea of how to achieve what you want.

1 Like

If the lines match up with each other you can use the ‘Remove overlapping lines’ optimization found under the ‘Optimization Settings’ in the ‘Laser’ window, then check the results in the ‘Preview’ window to ensure things are cutting the way you’d like.

image

image

Edit: I’m also trying the optimization suggested by Rick as well. I’ll post here once I figure this out. Thanks, guys!

Hey Blake -

Thanks for your reply. It’s all cutting. I’ll give what you suggested a shot. I imported the shape as a DXF and the rectangle in question is one continuous shape - I’m uncertain how to break it up into its constituent lines so I can delete a couple of them. Any ideas?

Optimizing by removing overlapping lines does not seem to have the intended effect. Every overlapping line is cut twice in the preview. I used “Arrange… Grid/Array” to lay them out, with 0 X and Y spacing. If I zoom in, at no zoom level do the lines ever appear to be distinct.

Back to breaking these into distinct lines for the time being…

I would need to see the art you are working with to better understand the results you are getting. When I draw a rectangle, then use the ‘Array’ tool to duplicate, creating 4 rectangles with the spacing of 0 on the X-axis, the result is as you describe with 3 locations where the lines overlap each other. LightBurn shows the selection marquee of these overlapping lines as “flashing” a bit differently than the “walking” marquee of a single shape.

For me, selecting the ‘Remove overlapping lines’ in optimization settings produces results as expected and the overlapped lines are cut only once when viewed in the ‘Preview’ window.

Are you saying that this is not working for you?

1 square arrayed, creating 5 squares. Duplicate removal didn’t do anything. Grouping them didn’t help, neither did converting them to paths.

I see now you’re talking about optimization settings. I don’t see an option like that in Edit -> Optimize Selected Shapes. Is there somewhere else to see those settings?

Using what you have created, click the ‘Optimization Settings’ button in the ‘Laser’ window, then tick the ‘Remove overlapping lines’ to ON (green) and then look at the resulting cut in the Preview. Moving the slider in that ‘Preview’ to see the cut process progression, are the overlapping lines being cut more than one time or are they removed?

You are using a different option to do the removal when selecting ‘Delete Duplicates’. LightBurn is aware that this duplicate shape deletion needs work as the current iteration requires the shapes to have a very close match to be removed. Work continues to enhance this feature.

Oh wow, I’ve never used that before. That’s pretty awesome. Thanks!

1 Like

Rick, yeah, selecting Remove overlapping lines in optimization doesn’t seem to work for me.

Here is a crappy video I just made: https://youtu.be/bW7BxIQLHL8

Ah interesting. It’s likely because the lines aren’t the same length. You have that 45 in there that is messing up the algorithm or whatever.

As Blake notes, the lines must be an exact match (or very close) for the removal to work at present. I’ll be expanding it to handle lines that partially overlap in the near future.

1 Like

Okay, sounds good. Thanks! In the meantime I can get rid of that chamfer and see if that helps. Then I can come back through and try adding it back as a standalone line.

In the case of the squares, another way is, array them, select all, do a “break apart” and then “delete duplicates”. in this way is working for me. Yes, break apart the squares put “inner/outter optim” off the game, but, in my case, is better select inners items and put in another layer than the imposible task of delete the duplicated lines manually
With the figure with a corner i cant get a good result, i think there are a important point to improve when they can.
With the corner, you can do a break apart, array them and then delet the short side manually … :frowning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.