My 80w diode laser will not work above 75% on my GRBL 1.1 controller and it has its own power supply

Hi Lightburn, i have recently bought a 80w diode laser, the attached picture, it connects to my GRBL 1.1 through a interface board with it own power supply, 12v 4a, but when i try running the laser higher than 75% power it just fires a single beam every 2mm, is there a setting to make the laser run at full power or should i be contacting the GRBL site for this info


Thanks in advance for you help

Your photo didn’t load properly. Can you try again?

What specific laser module and controller hardware are you using?

There isn’t a setting like you’re talking about that would cause this behavior but it could be a symptom of something else.

Does your interface board have a test fire button? If so, does it work at full power when pressed?

Hi Berainlb, here’s a pic of the interface, no it hasn’t a fire button, i’m using the 12v input from a separate power source and the 2 pin input to the interface, PWM with ground from my GRBL 1.1 controller, to fire the laser, the laser is 80w diode fixed focus from Aliexpress, hope that helps and thanks

laser info

General Specifications:
Model:450nm Laser
Heatsink Material:Aluminum
Luminous Color:Blue
Housing Size:42mm x 42mm x 90mm
Cooling Mode:12V 10000 rpm 40mm cooling fan
Optical Lens:φ9 Glass Lens
TTL&PWM Modulation:YES, Compatible with Both TTL & PWM Modulation
Wire Rod: 22# 2P2.54 Terminal Reverse Wire 80mm

Technical Parameters:
Electric Power:34.8-38.4W
Optical power output:4.5-5.5W
Effect power output: 80W
Laser Wavelength:450-460nm
Beam Shape:Dot ( Not Focusable )
Operating Voltage:DC 12V
Working Current:2.9-3.2A
PWM/TTL Input:DC5-12V
Input Interface:PH2.0-3Pin (+,-, PWM/TTL)
Safe temperature range:<70 ℃
Life Time:over 10000 hours


Is your photo not from current setup? Because that’s not what it’s showing.

What’s the maker of the controller?

Information about laser is scant and generic although this part stuck out to me:

It’s amazing that this laser can output more than the input. Probably the first of its kind in the universe.

There’s really not a lot of information to go on. The one thing I’d suggest is to make sure that the same value stored in GRBL configuration $30 (should be either 255 or 1000) is what is entered into S Value Max in Edit->Device Settings.

Also, do all power modulations lower than 75% appear to work? Meaning lower power setting equates to lower power output?

If you have a voltmeter you can check the pwm control line and see what it’s doing. That would eliminate one side or the other…

Always, wiggle and check connectors… These are a notorious weak spots.

I doubt it’s a controller issue they fail less often than the laser module…


hi, thanks for getting back, my controller is a woodpecker cnc and yes you are right the picture was one from file and not how it is wired now, the Laser is meant to cut 8mm ply in 1 pass at full power, it cuts 4mm ok at 40% but needs to do 4 passes at 75% on 8mm, just thought they may have been a quick fix, but not sure now, i have tried $30=255 and 1000 the same with S value Max, but it did not do anything, i will keep trying and contact the laser manufacture, will post the fix when i get one

cheers for now

8mm ply is tough for me to cut with my 44 watt OUTPUT co2. I don’t think it’s realistic to think a few watts would cut though that plywood. I have a very similar setup with at Neje 30 watt (input) laser and a woodpecker controller.

You should follow Lightburn Common Grbl Setup and stick to it. It is clear about the $30/spindle values.

Do you have a cheap voltmeter? The next step is easily determined with a couple of voltage measurements.


Hi jkwilborn, did what you suggested and checked the connection, i then removed the extra power source and fed the interface from the woodpecker board, what a result, 100% power, cut thought 7mm in one pass and 8mm in 2, thanks for all your help, i was over thinking it, thinking the woodpecker would not handle the power needed, but i was wrong, thank again

Glad it’s working but the result is odd. There’s no reason having its own power supply should have changed that behavior. Is it possible that the dedicated power supply was underrated for the task?

@berainlb is correct that is questionable.

I have an almost identical setup.

I run the ‘Neje stock’ power supply with their (power) interface board.

I run ‘two’ wires from the Woodpecker, ground and pwm from the Woodprcker board to the ground and pwm of the ‘power’ board from Neje.

That kind of current is too much for the Wookpecker, it won’t last long. Have one on the bench with dead outputs… oops…