My Fire button does not fire laser

Hi My laser master 2 20W laser. I’ll start saying that I have been using the laser for about 1 month with no problem. Now when I push the Fire button to center a project It is set a .50 does not come on. Also the laser when started to burn project laser looks like its on but doesn’t burn. any help would be great.

Have there been any recent changes to the laser, to the laser configuration, to LB settings?

Have you tried raising the power level above .5? Is it possible that it’s not on high enough?

A few things to check:

  1. What is the S Value Max setting in Device Settings
  2. Can you send output of $$ in console
  3. Can you share a .lbrn file where you see this behavior?

The GRBL version supports framing with the led on in low power mode. Hold the Shift key and press Fire.

Yes I tried raising the power and nothing the laser does not fire but when I run a project the laser fires up but does not burn.Not sure what you mean about question 3. Thanks

  1. What is the S Value Max setting in Device Settings
    Edit->Device Settings
  2. Can you send output of $$ in console

    Literally type $$ into the field that says (type commands here) in the Console tab. Cut and paste the results you get in the display window here.
  3. Can you share a .lbrn file where you see this behavior?
    You say that you’re not able to burn something. I assume you did this from LightBurn with a project that you created. That project is saved in a file of type .lbrn or .lbrn2. Can you take that project file and upload it as part of the reply? Either by pushing the up arrow icon or by dragging and dropping from Finder.

Just reset lightburn to see if that would help. I have run it yet though

You’ve got item 1 covered now but still need more for 2 and 3.

For item 2 I need you to type $$ into the yellow highlighted area and hit enter/return on your keyboard. Once you do that you should see text that is created in the purplish area. Select all the text there and copy it (command+c) and paste it here (command+v).

For item 3 are you able to locate the actual file using Finder? I need you to drag the file to the reply window. Or push the up arrow icon and navigate to the file location and select the file. A screenshot is not sufficient.

DrGupta.lbrn2 (1.1 MB)

not sure if this is what you want?

Okay. That wasn’t exactly what I was looking for but got what I needed. I wanted to check the value of $30. It is currently $30=1000. This should match what you had for S Value Max which it does.

The other setting that could affect power levels is if you set a Power Scale % in Shape properties. I just checked this in your file (and yes, that was what I needed) and this is at 100% so should be fine.

At this point, I don’t think this is an issue with software or configuration. This is likely a degrading of the diode or possibly a dirtied laser.

How many hours of burn do you think the diode has had? Do you normally burn at 100% power? This could potentially shorten life.

The other thing to check is to see if you have debris or residue built up on the lens. That can significantly reduce power. Try inspecting the lens carefully and cleaning it with IPA.

Adding @OrturTech here to see if he can provide any insight.

Maybe 300 or so maybe more.the most I ran is 92.5

what is IPA. Lol

Try running a test pattern on cardboard. Will give you a relatively good idea of how much the diode has fatigued.

IPA=isopropyl alcohol

You could use rubbing alcohol if you have that on hand. You want something that won’t dissolve any of the laser components and doesn’t leave a residue.

Does sound like a module issue

a) Could you check the 2 connectors on top of the Y stepper motor, Unplug them and look inside. Any discoloration on burn mark

b) If you put fire button at 20% and tap fire for a moment, does laser come on?

it did once when it first happened and nothing after that.

thank for all your help it most appreciated. Happy Holidays!!!

This is a very common problem on cheap diode lasers. Unplug the laser connection at the top of the laser module. Inspect the control board and look for burns or discoloration on the board. If you don’t see any, use some electrical contact cleaner and spray both ends of the connection/connectors. You can get contact cleaner at Walmart or any auto parts store.

Sometimes just unplugging and then plugging them back in works, but I highly recommend cleaning the contacts. I do it on all of my lasers every 6 mos.

If that doesn’t work, you’ll need to check the continuity of the wires from the control board to the laser with a meter. Or you can just open a ticket with Ortur at: Ortur Customer Support – Ortur Support Ticketing System
Gil is very responsive and will resolve the problem for you.

Rich