My laser burns when it is not doing a job but not when it is

Just got my laser set up (bought it in 2018) and it will frame out the job. The blue light is on but when I tell it cut the job it acts like it is doing it but nothing burns. Then when its at rest it burns a hole through whatever is under it. What am I doing wrong? Is it a setting?

What version of GRBL did you use?

i apologize I am using lightburn software.

In console window if you will type in $I then enter and paste results.
Also $$ and do the same.

paste it where? when i type it in it just says ok

It should give you a list of settings from grbl.

You can copy the output and paste it in your reply window.


when i type in $1 it says ok and when i type $$ it says ok thats all it does. am i doing something wrong?

Should be $I as in Information.
$$ in “type commands here” should have given an output.

When you machine connects, it will display a firmware message…

Use the console to copy/paste here so we can see the machine boot message?


i tried that one too and it says ok

we don’t see a boot message. we tried shutting it down and starting it back up and it didnt say anything

Strange, maybe I can invoke an expert like @berainlb to take a look.


If you right click devices in your laser window or disconnect and reconnect, what does it say in console?

image0 (1)

Is this a endurance laser?
You seem to have an old version of benbox firmware that I don’t think is compatible with Lightburn. But looks like you can reflash firmware to a version of GRBL.
Here is a link to look at. If this is the case we can help you thru it.
Benbox, LaserGRBL firmware | upload / reupload / fixing - parameters (

its a 3000 mw blue cnc. i bought it in 2018 and open the box…saw all the pieces and taped it back up lol. We just got brave enough to try it again this week. I am lost. The company I bought it from is closed and this is all the info I have

Stay brave and we can probably get you thru this. I’m no expert here, so I’m sure better minds will step in.

The controller is not running GRBL. It’s running BenBox as @Dskall pointed out. BenBox is not fully compatible with LightBurn.

The easiest way to upgrade the firmware is to do it from LaserGRBL. I suggest using the firmware named “v1.1h, custom, XY Homing 20190830”.

Go to Tools->Flash GRBL Firmware in LaserGRBL. Then select Target of Arduino Nano, then the firmware listed above. Select the correct port for your laser and then Ok.

More information here:
Flashing Grbl Firmware – LaserGRBL

Once installed, try reconnecting from LightBurn.