My laser tries (continuously) to "Home" outside of the boundary, grinding the laser in the 0 position... FAIL

First time poster… first time user… at least, I’m trying to be a user. I’m trying to do a test material 10x10 swatch and when the laser tries to “go home” (Homing) it gets to 0 X&Y and doesn’t stop… grinding the motor because it’s buried in the corner.

I have a TwoTrees (Sculpfun) S9 laser, or it “found” my laser as GRBL… I haven’t messed with any presets. I am stuck and have NO CLUE what to do now.

I just quit out of LightBurn and went back in… it’s already at 0 X & Y, but it trying to go further grinding the motor and I got this error message:

“Waiting for connection…
�i,�ok
ok
[VER:1.1h.20220925:]
[OPT:V,15,128]
Target buffer size found
ok
Homing
ALARM:9
Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.
ok
Grbl 1.1h [‘$’ for help]
[MSG:‘$H’|‘$X’ to unlock]
ok”

Which laser do you have? TwoTrees and Sculpfun are two different brands and different lasers…

First of all, do you have limit switches installed? If not, place the laser head in the 0,0 position before starting lightburn.

I ordered a TwoTrees, but… it says Sculpfun, so I guess I have a Sculpfun S9. Sorry, I know I sound dumb. I’m pretty tech-capable, so I’m SUPER frustrated. :frowning:

No. it didn’t come with limit switches… or if they need to be installed, I don’t know how to do that, so no, I probably don’t. I have put it in the 0,0 position. It doesn’t seem to matter. It makes noice no matter what I do, so far. I can’t find anywhere, where to adjust the homing coordinates.

If you don’t have homing switches then disable “Auto-home on startup” in Edit->Device Settings.

While the machine is powered off slowly move the laser head to the front left of the machine. Then power on. This process is considered “manual homing”.

Change “Start From:” mode in Laser window to Absolute Coords. Try jogging your laser in Move window to confirm function. Then create a simple rectangle. Then try framing.

If those things work then you’re likely good at that point.

I have some in-depth documentation for Sculpfun lasers here: Quick Start & Overview - Diode Laser Wiki Maybe start there. There is also an article about the coordinate systems: Coordinate systems & workpiece alignment - Diode Laser Wiki

The S9 is a good choice, by the way. The module should be much more capable than the TTs one :slight_smile:

Thank you! Its good to hear I didn’t buy a dud! :smiley:

1 Like

I had a similar issue because “start from” setting was changed to “user origin” instead of “absolute coords”. (My cat went on my keyboard). No problems with “absolute coords”.