My NEJE 2S A40640 Laser is missing steps - need help

Hi team,

Can you help me please to find the root cause of my issue ?

My laser is missing steps. I tried to tighten the belts but same issue.

It’s looks like the problem appear only when I engrave large circles, because I tried to engrave (Fill) small circles, but it’s done very well (see last photo on the post).

My laser is making strange noise when mooving.

Thank you


It would be good to see the ‘cut settings editor’ for this file.
Quite often it’s a speed issue, slow it down and see if that makes a difference


If you motors are making noises, like knocking, it’s likely you’re trying to move or accelerate them too quickly… The fields are moving faster than the mechanics can respond.

This also causes the machine to lose steps or not know where it is…

It really depends on what the noise sounds like…

You can post your machine settings with screen shots or most grbl machines allow the $$ command to dump them to the screen and you could post them…

Are you running mm/m or mm/s?

There is very little adjustment room on these belts as they are timing belts and very small amount of stretch… virtually unnoticeable.

I can’t tell you how to adjust these, but too tight or too lose it causes issues… Figure what seems to tight and too lose and put it in between in the middle…


1 Like

Click the Preview icon along the top bar in LightBurn. It looks like a flat panel monitor on a stand.

Select the ‘Show traversal moves’ switch at the bottom … I set this up to attempt to demonstrate what I believe i’m looking at.

The red blocks on either side of my image represent the ‘Overscan’ - the distance it takes to slow down and change direction when raster engraving.

It appears to me that your engraver is hitting the frame rail on the left because the left side of the crest is flattening and everything to the right of that is getting bumped over.

There are a few ways to resolve this. Move the crest away from the Left side in the workspace, Slow down, make the crest smaller, or turn off Overscan (as a last resort).

When this happens it looks fine in the workspace but shows in the preview window with the Traversal moves showing.

Let us know.

1 Like

Thank you, you are right. I tried to reduce engraving speed from 18000mm/min to 9000mm/min and the job is done very well :slight_smile:

How to extract job command that you need to view ?
I’m a beginner on Lightburn and laser world :slight_smile:


1 Like

I checked the preview and the red lines don’t across my working area. My issue was the engraving speed.
About the noise, I need to check the motors and sliding mechanism.

Thank you for help :slight_smile:


Wasn’t this what I said in post #1 :joy:

Glad all is well :+1:

1 Like