My Rotary Home Position is a moving target

I have a rotary tool that came with my OMTech/JPT M7 MOPA fiber laser.

I can’t get this to go back to a home position to save my life! It keeps making it up.

I had the hopes of using the Repeat Marking feature in LightBurn to make this work.

I am running this rotary tool facing up or vertically with a jig to mark 20 pens at a time.

To prepare:

I have made sure the steps are correctly set to 12800.

I don’t see how diameter matters since I am using degrees of turn. The diameter doesn’t matter does it?.

That said, I do have the diameter of the chuck at 3.14196In or 80mm for the object diameter

I set the Zero mark to a start point and confirmed it had set the start point by pressing Go to Zero.

To check all this I set the count to 2 just to test it on 2 items and placed them 180 degrees apart.

However The YouTube is here

It moves the burn target just a few degrees short. It is quite apparent on the second item marked.

When it returns, it returns just a few degrees short of a full 360-degree turn; the Home Position.

If I ask it to go “Home” or zero. It moves to this new spot and not the zero point I first assigned but this new endpoint

If I repeat the job, you can see it has moved just a few degrees short on each attempt.

What would you recommend?



Diameter doesn’t matter. “Enable Rotary” should be off in the rotary setup. I experimented with this and found the direct drive with a large table had too much mass to start and stop accurately. If you are just using angle, switch amperage switch 4 to full, and reduce steps to 360 unless you want to stop at 22.5, then 720. Slow the acceleration down.
I ended up building one with a 10:1 worm drive reduction, works 1000% better then the 1:1

Thanks for the comment and how you solved it…

I was wondering… we were talking about timing of the jobs relative to the rotary and the Lightburn thread being in the background. I made a comment that if these jobs were sent to the fibers memory, it should not have any effect on job time.

Oz corrected me advising that a rotary isn’t handled the same way, Lightburn waits for the rotary to complete before sending the next operation…

Turning it off may be appropriate… I’ve never tried using it with it turned off… now I’m :thinking:


1 Like

I’ll give it a try. Thanks a million for sharing!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.