My Ruida based laser is etching lines during slews

As you can see, there are lines being etched between every move. I originally had fill turned on for all of the text. With cross hatching turned on you just end up with etched blocks covering all of the text. The same is true if you place a box around the QR code. You just end up with a large blank square where the QR code should be. The laser is set to 500mm/S and 7.5% power. That is absolutely the lowest power I can set to get any etching at all. It’s like the beam is always on. Just like framing mode. All this has happened since I switched to Lightburn. Even files that have always worked previously that are stored on the laser now have lines. I used to just load a file from RDworks onto a USB stick and transfer them to the laser. Then just hit run. Those files now simply have lines on every move too. I’m running Lightburn 1.1.04. It’s like it’s changed something on the laser. Lightburn detects a Ruida RDC544XG.

It’s like the laser is always above threshold when the XY gantry is moving.

Any help is appreciated.

I might also mention that the preview looks correct but as the laser is engraving, the image on the controller looks like lines scribbled all over the display. In the case of a QR code etch the image just looks like scribbles. In order to print his card at all I had to set fill to shapes individually. Otherwise the image is just etched away into the scan lines.

Thanks again

If this happens with files that already worked and have ‘lived’ on the laser, then it’s not Lightburn.

Lightburn will not change your configuration unless you direct it to do so.

This sounds like some kind of hardware failure…

I doubt that the controller is an issue, the other parts of the image appear that it’s operating.

The tube needs a high voltage potential to lase… my accumulated knowledge tells me the tube won’t lase at a lower voltage if it’s failing… from what I’ve seen…

That makes me suspicious of the lps.

A mA meter is nice, but if it’s lasing, it’s drawing current.

Does it start lasing as soon as the machine start to move to move the head to it’s first area?

I think, I’d try pulling laser enable “L” on the lps low and see if it fires, with/without the controller on, just the lps. It sounds like the lps is firing as soon as the laser enable goes low…

Follow me?


It’s unusual to see a Traversal Line engrave on a Ruida controlled engraver.

This was a previous diagnosis:

The laser has been operating fine for years. It literally started doing this the day I started using Lightburn. I’m not really complaining about LB. What makes me think its not hardware is the curious phenomenon of the “scribbles” that appear on the DSP controller’s display. As I said, the preview image looks correct but the display on the controller looks like a kid with a crayon. Every line that appears in a crosshatch gets etched. If I turn fill off and restrict it to line drawing mode you get what I showed in the photograph above. I will take a picture of the DSP display tomorrow and show the “scribbles”. One thing I’ve noticed is that I don’t appear to have the passwords for getting into the factory setup or reset screen. RD8888 and RH8888 don’t work. I obtained this laser in 2017 it’s been running since then.

Thanks again for the suggestions.

Before any resets, make a backup copy of the Ruida configuration so you can restore the laser manufacturers ‘factory’ settings. You will lose those settings if you factory reset the controller.

Edit → Machine settings → save

You can try putting a voltmeter from ground to LPWM1 and see if it indicates any voltage.

Good luck


Some controllers allow the file to be exported on a memory stick.
If your controller allows the file to be exported it may be worth a look.

Once you have that file on the memory stick and if you’re willing to share it - change the filename suffix to .txt and upload it here. Someone may be willing to open it in a similar controller to see if the results are the same.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.