My Sainsmart 5500mw blue diode laser will fire but not burn/engrave

Hi all!

In a nutshell… bought Sainsmart 3018 Pro with 5500mw blue diode laser, downloaded and installed everything on my macbook pro… seemed to work fine, just had to fine tune the settings… then all of a sudden, LightBurn would not recognize my laser anymore. After 2 hours of trying to make it work, deleted and reinstalled drivers… voila! But nooooow, I can see the beam, and it moves just fine all around… but it just won’t burn at all! Not even a paper napkin!

Please help!

I am new to lightburn and had the same issue. I googled laser fires but not engraving and there were a few hits. I am not sure of the exact setting I made but there was a speed setting I do remember. I believe I also saw something about the laser power setting for the fire button being too low.

Try this link, it has the initial settings for your machine. I need to verify my settings also.
Good luck.

Hey Greg, thanks for the quick response. Already have gone through a lot of topics in various places… sadly, nothing has worked so far. I do admit I’m a complete newbie when it comes to these machines. My settings right now are as follows:


Also, my S-value max = 255.

Read the paragraph that starts with this:

With GRBL, in variable power mode, if you ask the controller to go faster than it’s allowed to, it will reduce the output power to compensate .

Your maximum speed ($110 and $111) is 500 mm/minute, which is very slow (8.3 mm/sec)

1 Like


Thanks for the response. Forgive me for what might be a dumb question, but…

If my settings for $110 and $111 are to slow, wouldn’t that cause a completely different problem? Right now I can barely “scratch” the wood surface… wouldn’t going too slow cause burns?

If you burn a line at 100% power, 100 mm/sec, it would burn the same as if you ran the same burn at 50% power, and 50mm/sec. Going half the speed with half the power (in theory at least) dumps the same amount of laser power onto the wood, and will darken it to the same degree.

What’s happening is that GRBL knows how fast it is allowed to go, and how fast you’ve asked it to go. If you ask it to go twice as fast as it can, it knows that won’t work, so it figures out how fast it can go, and what the correct laser power would be for that allowed speed to give the same level of burn as you asked for at the requested speed.

If your maximum speed is 8 mm/sec, and you requested 32 mm/sec, that’s 4x faster than it’s allowed to go, so it drops the power by 4x instead, giving you the exact same burned result as you requested, just slower.

Going too slow only causes burns if you set the power too high.

I’m still lost on whether I’m moving too fast or not fast at all.

What $$ settings do you recommend @LightBurn?

The ones that work for your hardware. That’s a crap answer, but it’s the only one I have - I do not have your machine, so I can’t tell you what will or won’t work. What you have is a CNC machine driven by leadscrews, geared and designed for low speed, high torque, low GCode throughput work. What you’re trying to do with the laser is effectively the opposite of all of that - lasers are lightweight, so they don’t need high torque, and engraving images involves processing a LOT of gcode per second, which 8-bit GRBL is not really built for.

Buying one machine to handle multiple types of work, where those different things require different design goals, is always going to be a compromise. In this case, all the compromising is on the laser side I’m afraid.

Love the “That’s a crap answer, but it’s the only one I have” bit… hahahahahaha

I appreciate your honesty… but that means I’m back to square one.

I really hope someone else will be able to help.

Thanks again for your help and honesty Oz.

How fast are you trying to run your files? If you’re attempting to go any faster than the max speed limit in your firmware, the controller is going to automatically reduce the power to the laser. If you got exactly the max speed (or less), then the only power management will be from acceleration and deceleration, which is normal, and then you can set your power % as usual, and you’ll have more control.

I would just start with that for now and see how far that gets you. You’ll need to experiment a little to dial in the right settings, but if you’re working within the range of speeds allowed by the machine you’ll at least be fighting it less.

I really don’t mind going slow… I just wanna get going!

I’ll find out what the speed limit is on my firmware… adjust to that… run a test at 100% laser power… and we’ll see how it goes.

Thanks again Oz!

I noted it in a previous post here ^^

See that’s the thing… Even at that speed, I set the laser power to 100 % and I can’t get a burn on a paper napkin! Needless to say… when I try to engrave wood… nada, zip, zero

THAT’S exactly why I’m so confused…

In that case you might have a dead diode. “Even a paper napkin” isn’t a good test if it is a pure white napkin - white reflects visible light, so it doesn’t burn well with a visible light laser.

Alrighty then… ummmmmm… don’t exactly know what happened but… laser started working and burning. 2 things I did:

a) Changed $120, $121 and $122 from 3000 to 5000
b) Put a piece of kraft paper because of the failed pure-white napkin test which I didn’t know that it would reflect the laser instead of burning.

It works! Still have to work out of couple of details BUT… back on track. Thanks Oz!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.