Need help lightburn not working

THANKS for all the help, I got it going. YEA!!!

@olddogTim we often get so excited when something finally works and completely forget to tell everyone how problem was fixed. These forums are often read by people with identical problems and we must always remember to share what we learned, regardless of how silly that may be. I’m sure everyone here who helped you would love to know what the problem was, even if it was as simple as a dud USB cable/stick. Saying “I got it going.” really doesn’t help us, or the next person and that forces them to go through the same agony. Please always share :wink:


Not quite sure just did the same things I was doing for the last 2 days, that was what Bonjour Bo said to do. I may have disconnected the USB cable instead of turning off the laser when I reloaded the device driver. And (you need to uninstall them. If it said the best drivers were installed, you must have told it to update/refresh them. That just tries to reload the unhelpful driver.) what Bo said.

1 Like

I’m surprised you even had to load drivers unless you’re using something other than Windows 7-10 Windows installs drivers automatically.

I have a Red and Black 80 watt. I installed Lightburn, plugged in my USB cable and everything worked fine from the outset. I love my new machine.

Glad it’s working. The joy of Laser Cutting is NOT being bogged down with computer woes.

I was using it for months then one day I turned it on and nothing, no communication between laser and computer . Using windows 10 64 bit

When you are in Lightburn look down at the bottom right hand side. Where it says “Devices” It should show your device. If it does not click on “Devices” and see if the configuration is still there for your Laser, if so click on it, if not then reinstall it. Do this while the Laser is turned on and connected via USB ( if that is what you use).

I know this may sound dumb, but I did “house visit” computer repairs for years ans in many instances the person had a similar problem - everything was fine and it just stopped. On almost every occasion it was a lose connection. Even one of the Sata cables on my own PC loses its connection every three months or so and I have to re-seat it.

My new 80 watt Red and Black is notorious for losing communication with the computer. The USB port is set up vertically on the side of the machine and the physical weight of the cable is enough to work the plug loose. It should be horizontal,

Because full-size USB connectors are the most useless things ever invented, try to set up the cable in such a way that it’s not putting any weight on the connectors. I prop my cable up on a nearby table and as long as it stays there I never have any trouble.

The problem was solved, a few days ago!!!

1 Like

Which is, as Tim described, his problem. Microsoft doesn’t have every driver, only ones submitted for validation.

Windows driver management, driver signing, is nearly as awful as windows serial port management.

And Chinese USB/serial drivers are notoriously difficult and problematic, on Windows, Mac and Linux.

Cloned hardware and cloned drivers to support it. Bad driver versioning means windows driver manager can’t validate the driver against its lookup table.

The only real way to solve it is to remove the driver entirely and load the correct one, either from the machine-provided source or from the driver chip manufacturer, which is what Tim did, after a few missteps.

When a driver doesn’t have the correct designator, windows doesn’t have a clue what to do and just reloads what it can find.

And this is enough of a problem with windows that they have developed end-user tools to validate and test API/driver functionality.

What do you mean " which is what Tim did, after a few missteps. " I was doing the misstep waltz, the long version!!!

1 Like

I am not a fan of dancing :wink:

Me either that’s why it took me 3 days!!!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.