Need help lightburn not working

Need help lightburn not working it says file transfer failed. laser may be busy or paused. this happened before and I had to turn on the laser first then lightburn but that does not work anymore. Also lightburn can not find my laser in devices " find my laser"

Do you have the laser plugged in to the computer? How are you trying to connect?

Right-click the ‘Devices’ button to re-establish your connection.

That didn’t work . when I plug in the laser in to the computer it beeps like it sees it,but nothing else.

What are you plugging in? What type of connection? If USB, make sure you are plugging the USB cable into the correct connection for your controller and not into the USB Stick plug if you have one. That is a common connection issue. What else can you share to help us “see” what you are dealing with? Have you been able to use LightBurn with this laser in the past? If so, have you mase changes to this setup we should know about?

Have you tried to connect using the original software that came with your Trocen?

Two days ago it was working USB cable is in the right way never used anything but lightburn, cant find original software.

I would reseat connections at both ends and also test with a different known-good USB cable. You could try to manually create a new Device Profile, named differently, and see if you can connect using that profile. Did you recently do an OS update?

And this might be worth review:

Tried different USB cables, A different computer also nothing. I already set the USB ports not to turn off. Does the USB cable go to the Trocen controller TL 3120?

I do not know what you have nor how it is configured/wired in your cabinet beyond the information you have provided, but I would assume so. Why are you asking?

This is why I asked you above to check where you are connecting.

If you post some pictures, we might be able to direct you further.

Will have a look tomorrow at the wires maybe one came lose . After trying all day I need a break.

Good point. Sometimes there is a cable from the controller to a connector on the cabinet. I have seen these exposed USB connectors “stacked” in the cabinet together, one for connection to computer and the other for USB Stick. Again, hard to say without seeing how you are configured.

The TL-3120 has a USB-B female socket on the mainboard, with a USB-B male to USB-A female to a panel-mount socket on the side of the case.

It’s not unheard of to have a problem with the controller-panel connection.

1 Like

NEW I went to device manger when I was plugged in to the laser and it showed that it recognized AWC USB device but the drivers were not installed . I tried to update the driver but no success, I looked to do it on the web and in my computer but it could not find any drivers, Any ideas.
What does (Device descriptor failed) mean? that is what I am getting when I try to load the driver.

It means it’s not happy with the driver.

right-click, select uninstall, give it a minute, then disconnect and reconnect the USB and it should find the correct driver.

Should - but Anywell aren’t great with signing their software, so your best bet is to install LaserCad and choose the ‘install USB driver’ pulldown.

It’s all in here:

I tried that and it finally said the the best drivers were already installed BUT, Device descriptor failed, came up again. I think my controller is sick I can work it manually with the buttons but not with software. What would be a good Rudia controller to replace it with?

The 6442G and 6445G are both excellent and well supported. The 6445 is newer and has a large display screen, but they are more or less functionally identical.

you need to uninstall them. If it said the best drivers were installed, you must have told it to update/refresh them. That just tries to reload the unhelpful driver.

Track it down, remove it, install laser cad and check the ‘load drivers’ option and try again.

If your controller is responding and you can trigger a pulse, don’t assume its broken - they are robust.

Bo is correct here - Most likely it’s a configuration issue on the computer side. If your controller has an Ethernet port, you could connect it with an Ethernet cable and not need a driver at all.

That model of AWC doesn’t have Ethernet:(

Phoo - I didn’t far enough back to catch the controller model.

No Ethernet