Need help to set up grbl


(doyen smith) #1

i have a k40 with a grbl controller

having problems with workspace and origin, unit homes ok but workspace out of bounds
when i use the laser position its just half the bed and its not the right location

everything is all over the place

this is my grbl settings

$0=10

$1=255

$2=0

$3=0

$4=0

$5=1

$6=0

$10=31

$11=0.010

$12=0.002

$13=0

$20=0

$21=0

$22=1

$23=1

$24=2000.000

$25=2000.000

$26=250

$27=2.500

$30=1000

$31=0

$32=0

$100=157.000

$101=157.000

$102=160.000

$110=12000.000

$111=5000.000

$112=5000.000

$120=8000.000

$121=3000.000

$122=3000.000

$130=320.000

$131=230.000

$132=200.000

ok

i tried ​ G0 X0 Y0 and ​ G0 X-320 Y-230 no luck


(Oz) #2

Depending on the version of GRBL you’re using, you might need to set a workspace offset. LightBurn only works with positive workspace. Read here for more details: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md


(Phil Stevens) #3

Also $32 should de set to 1 to prevent traverse lines being burned.


(doyen smith) #4

i did all of that settings the laser head still crashes anytime i click anywhere on the workspace


(Oz) #5

Where is the origin of your machine? If you use the manual jogging buttons to move the laser head into the work area, then click “Get Positions” what does it report back?

You’ve said you have a K40 with a GRBL controller, but not said which type. GRBL configured for CNC use is usually set to work in negative workspace, which would mean you’d need a workspace offset, as described in the link I sent above.


(doyen smith) #6

thank you for the reply

my apologies

im using a saint smart grbl controler with grbl 1.1

when i click get position it reports ntn in the position box

also it i use laser location and click anywhere on the workspace the laser head dosent go where i click it just move couple mm


(Oz) #7

“ntn”? As in, those are the exact letters displayed?

When you power up your machine and connect LightBurn, does it home? If so, where does it home to?


(doyen smith) #8

when i click get position the info box is blank

when i power up the machine and connect it to lightburn it homes to the rear left


(doyen smith) #9

this is what i am seeing now when i click get position


(Oz) #11

So your machine is reporting the position X: 317.5, and Y: 3632.5.

If your machine is homing, and zeroing when it homes, those numbers should be X:0 and Y:200 or thereabouts. You have your origin set to the rear left instead of front left, so you should change that, and your $10 setting should be set to 0.

Can you copy & paste the output that your controller sends when you type $# into the console and hit enter?


(doyen smith) #12

thnaks for the response, i notice the grbl controler was the problems so i have purchased a mini gerbil for k40 laser from awsometech should be here tuesday so ill let u know the outcome.


(system) closed #13

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.