Need help with error

After I used the rotary i now get an error and can only home or go to origin.
Starting stream


G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)

On or near line 2:

Stream completed in 0:00

[MSG:Reset to continue]


Ortur Laser Master 2 Pro S2 Ready!

OLF 183.

[MSG: Flame detector active,Ambient infrared value:0]

Grbl 1.1f [’$’ for help]

[MSG:’$H’|’$X’ to unlock]

[MSG:Caution: Unlocked]


Did you make any machine settings changes when you enabled the rotary? If so, you’ll need to change those back if you want to use the laser as normal.

Specifically, did you disable soft limits and homing? If so, reenable them.

As general practice, always take a backup of your original configuration before making changes in case you need to get back to them.

Yes I saved the default and made changes for rotary then re loaded them to set them back. I have even tried removing and reinstalling laser still get error.

Well done there. But odd. Perhaps try resetting the configuration with “$rst=*”.

Do you get this message when jogging with the move controls?

Another thought. Could it be that you’re using “current position” in Start From in the Laser window? If so, change to Absolute Coords.

Thank you berainlb i did the $rst=* and homed solved the problem for now at least. Thanks

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.