Need help with LB bridge

Well, when I hooked up the bridge kit to my macbook pro I had no problem finding it and it worked. Today I tried to hook it up again and no matter what I do I cannot see the Bridge from my Mac. I am at my wits end and could really use some help.

You’ve posted this now to 3 separate threads so you’re likely to get fractured responses. Since this is a topic dedicated to the purpose I’ll respond here.

Some troubleshooting questions:

  1. Can you attach a screenshot of LightBurn? The full screen please.
  2. What have you done to attempt connection thus far?
  3. Are you getting any specific error message or indicator that things are not working?
  4. Have there been any recent changes to your Mac, to the laser, or the network configuration?

So after messing with trying to get the Bridge hooked up to LB I finally got it to connect. And it worked great. But the problem arises when I shut it down and go back to my network modem. When I reopen LB and try to reconnect to my laser is when I get caught in a loop. When I go into LB I change from my modem to the bridge. When I do that the page comes up and asks for my Network SSID and password. When I do that my mac deselects the bridge and goes back to my network. When I select the bridge again it goes back to the page asking for my network ad infinitum and never says ready.

  1. Full Screen pic

  1. I try to connect per the instructions in LB.

First I connect the bridge

Then this page comes up

When I enter my SSID and Password my wi-fi settings go back to my modem.


In LB I reselect the bridge this page comes up again and round and round.

  1. No error messages

  2. No changes to my Mac, to the laser, or the network configuration.

It seems like the bridge can’t connect to your XMODEM network. Can you confirm that the password is correct? Trying pushing the crossed-out eye to confirm what you’re typing is what you expect.

Perhaps try to disconnect from XMODEM on your Mac and reconnect to confirm the password.

Thanks but the password is good. When it does connect it works flawlessly.

When was the engraving done? Today? Can you see from your router that the bridge has connected or can you see connection attempts?

Try power cycling the router. It may not be accepting new connections or has reached some limit.

I have a question for you, good Sir. What is the procedure for reestablishing the connection of the bridge when I first open up Lightburn? Should I be connected to my bridge or to my router when I first open LB? Then, do I have to open up the devices window and rerun the Lightburn bridge discovery wizard?

If you have lost connection momentarily, control + click on the “Devices” button. That should reconnect and show the laser model controller at the bottom of the screen.

The connection to the bridge should only be done as a one-time setup. So stay connected to your standard wifi router.

No. Again, this is a one-time setup.

I’m not familiar with ctrl+click but if this doesn’t work try right-clicking on the button.

Also, can you confirm the version of LightBurn you are using? If it’s not at least 1.0.04 can you try updating? Apparently there was a change made to increase the timeout time to communicate with the bridge.

I am about to give up. I got it to give me this screen.

Then I select Rudia 664XG in LightBurn and it says disconnected.

I just don’t know what I can do anymore.

Have you tried right-clicking on “Devices”?

Can you confirm version of LightBurn please?

Success! Thank you for all the help.

And I can shut it all down and it comes right back on!

What was the final difference maker?

Well, you were correct about the wrong password to the modem. One letter was lower case instead of upper case but it still did connect 2 previous times with the wrong password which was strange. I figured it out by logging into my modem. Unfortunately I didn’t know the user and password to the modem. Well, I figured it out and got the correct password. However, after that, it still took me many tries to get it to connect properly. But when it finally was connected it worked perfectly. I think the problem was that I initially put in the wrong modem password. That set off a chain of events because everything (the modem, the network settings, LightBurn, and the bridge itself got messed up. Re-flashing the bridge would reset everything on the bridge but the modem and networking on my computer kept fighting me. After more than 100 tries I finally got it right. Thank you very much for helping me during the Christmas holiday and Happy New Year! :grin:

Well I guess you now have a journal for how to troubleshoot in case this every comes up again. Thanks for documenting for others that might run into something similar.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.