Need help with Lightburn settings for my Xtool, my workspace is very small, like half the size

Hello, i am new to lasers, recently got me an xtool d1 10w and trying to get sorted and known with Lightburn, got me a wastegrid i am now trying to engrave into my workspace but it only become like half the size.

From 390x390mm and when i burned it it ended up at 185mm.

Units/grids is set to mm/min Visual Grid spacing 10.00
My device settings and working size shows 432x406 mm

When in workspace in lightburn all measurements look correct when i align the grid in the window and i do not really get what could be wrong so i try ask instead since google make my head hurt now after several hours with no answers =)

XOXO Knutsson - Sweden

Do you possibly have rotary enabled?

No thats not on… =(


Sending some screens from devices menu if this is correct, someone suggested on a forum that it might be wrong

Can you provide the following:

  1. Full screenshot of LightBurn with the design loaded and Cut window and Laser window showing
  2. Screenshot of Edit->Device Settings

Here we go, just went trough Xtool creative space and it says all firmwares are up to date.
But when i am in Laserbox basic and try check firmware it just disconnects, if anything is failing here? Just thought i would mention it incase it has something to do with the problem.

I don’t see anything obviously wrong in the screenshots.

Have you tried running a job in XCS? Do you see the same problem?

Can you describe the problem a little more? Are objects half size in both X and Y or only in one dimension? Do shapes burn well but just smaller? Or do they show other issues?

I have not tried do the same work in XCS but i can do it in a jiffy, All objects are half the size
Sorry for shabby pictures but it look clean and crisp irl exept the “test” which i had to much power, it should be 10cm but ended up as 5cm.

I could not use the file intended but i made a 40x40cm square in XCS and used framing, and it was framing correctly so i get 100% size in XCS but only 50% in Lightburn wierdly enough

Can you take the same grid design and then use File->Save Gcode, then save to a file with .txt extension and then upload here? I want to see if the gcode is being generated incorrectly or if the laser is interpreting incorrectly.

390x390-grid-V2-Metric.txt (62.8 KB)

I do see the bounds are totally incorrect measures in the txt, maybe we have found the problem, i will try do something small exept the grid itself to see if its the same

I think the coordinates is due to laser not being homed.

Make sure you have the laser head at top-left before starting your machine. Then never move the laser head by hand. Use the jogging controls to move the laser.

I’ll take a closer look at the gcode in a bit.

I think it´s sorted, i made a 395x395mm square in Lightburn and it works as intended, something was up with the gridthingy and when i saved it as toolpath it messed up the rest as well so now i believe it will work correcly… Thanks for the awesome support, felt like a beginners mistake but now i can get this thing rolling!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.