Need Help with SVG Logo Engraving - Mirroring and Resizing Problems

Hi fellow Lightburn users,

I’m facing some difficulties while using Lightburn software for my laser engraving projects, and I could really use your expertise and insights to resolve these issues. Currently, I’m experiencing two major problems with the SVG logo I want to laser engrave, and I’m hoping someone here can help me out.

1. SVG Logo Being Engraved Mirrored I have noticed that when I attempt to laser engrave an SVG logo, it is coming out mirrored or flipped. This is quite unexpected, as I want the engraving to be an exact representation of the original SVG file. I have tried adjusting various settings in Lightburn, but I haven’t been successful in resolving this issue. Has anyone else encountered this problem before, and if so, how did you fix it?



2. SVG File Resizing Error Another problem I’m facing is related to the resizing of the SVG file. I want to engrave a circle with a diameter of 55mm, which should be equivalent to 5.5cm (I double-checked my calculations to make sure I’m not making any mistakes). However, when I send the job to my laser engraver via Lightburn, the engraved circle comes out with a diameter of approximately 17mm, which is nowhere near what I intended. This resizing issue is puzzling me, as I’ve followed the correct steps to set the dimensions accurately.

I’m not sure if I’m missing something in Lightburn settings or if there’s a different approach I should take when importing SVG files for laser engraving. Your guidance and suggestions would be immensely valuable to help me overcome these challenges.

If you’ve encountered similar issues or know how to address them, please share your knowledge with me. Any tips, advice, or step-by-step solutions would be greatly appreciated.

Thank you in advance for your assistance!

It is probably the machine origin. Edit → Device Settings

Did you follow some guide on how to set these up?

It should not rotate the object like I see in the photo…

Why are you scaling anything?


Hey, Jack!

Thanks for your response. Yes, that’s the place I was referring to. I had it set to Bottom Left, but you mentioned the Machine Origin might be the issue. So, I was thinking of trying the Top Left option to see if it resolves the mirroring problem. Do you think that could be the cause?

Regarding the scaling, I actually didn’t intentionally scale anything. As you can see from one of the screenshots I shared earlier, the width and height of the circle are both set to 55mm, which should be correct. However, when I laser engrave it, the actual engraved circle turns out to be much smaller, approximately 17mm in diameter.

I followed the tutorial you suggested (3018 PRO - Getting started with Lightburn - YouTube), but maybe there’s something I missed or didn’t quite grasp. Could there be any other settings or steps in Lightburn that might be causing this resizing issue?

I appreciate your help and any additional guidance you can provide to resolve these problems.

Thanks again!

Does this machine home when you power it up?

if so, which corner does it home ?

If not, how are you doing it manually?

Usually the image is flipped across the perpendicular between it’s locations…

I’d guess, in your case that it should be the bottom/right, assuming that’s where it homes.

If the machine homes, you can use the move tab in the cut/layer window to get the current position, it should be 0, 0

You might have to do a Window → Move and enable that tab.

Suggest you do a refresh of the Lightburn Job Origin and Coordinate system documentation…

Good luck


Thanks for your continued support. I managed to solve the mirrored issue by adjusting the machine origin settings as you suggested. So, that’s sorted now.

However, I’m still struggling with the resizing problem. As you can see in the new screenshot I’ve shared, the ‘150€’ SVG I imported was created with dimensions at about 20mm/2cm in width. Yet, when I laser engrave it, it’s only coming out at around 0.6cm width.

I’ve already set the SVG import settings to 72dpi, as I’m creating these SVGs in Illustrator. I double-checked the dimensions in Lightburn, and they seem correct there too. I’m not sure why it’s not engraving at the intended size.
Perhaps there’s something I missed in the documentation that could help me troubleshoot this resizing issue.

Thanks again for your assistance. I’m determined to get this right, and your advice has been invaluable.

Best regards,

If I convert mm to inches… 20mm/25.4inches/mm = 0.78 inches…

I’d speculate that Lightburn is working in different units than the machine. Lightburn in inches and the machine is mm… or vice versa…

Set both machine and Lightburn to the same units…

When you did the Device settings, did you pick mm/m, inches/m, mm/s or inches/s.

Clicking mm/inches up top just changes the displayed unit.

Check to see if $13 is set to 1 or 0 … and correct it or Lightburn

$13 is defined as Feedback Units, Sets position feedback units from mm to inches. $13=1 for inches or $13=0 for mm

I have all my stuff set to mm/s.

Many use mm/m for led lasers. They are generally slower… I’d still rather enter 25mm/s than 1500mm/m… Just like a car, if it’s k/h or m/h… it’s moving the same speed… whichever units you are most comfortable with.

I suggest you check/change them through the Lightburn Edit → Machine Settings, don’t forget to write it to the controller… Always a good idea to save these to a file in case you change something you didn’t mean to or don’t remember.

You can also change these via the console by entering $13=0 or $13=1

What gets sent to the machine is just the number of units, they are not specified as to what the units are… If the software and the machine have different units (one in mm the other inches)…

For example… if Lightburn is set for inches and you draw a 3 inch line…it commands a move, the machine will move 3 units… if the machine is in mm, it will move 3mm not the 3 inches you are expecting…

Make sense?

If you have issues, sing out.


Hey Jack,

Thank you so much for your insight! It totally makes sense now. As you pointed out, the SVG I created in Illustrator was in millimeters (mm), and I didn’t consider that Lightburn might be set to inches (in) by default.

I just checked the Machine Settings, and indeed, the $13 parameter is set to 0, indicating that it’s already configured for millimeters. So, theoretically, it should be receiving mm units, right?

However, despite this setting, the resizing issue persists. The ‘150€’ SVG, which should be approximately 20mm in width, is still engraving at around 0.6cm.
I’m a bit perplexed now as to what could be causing this discrepancy. Is there anything else I should check or consider to ensure that the SVGs are engraved at their intended dimensions?

Your help has been invaluable, and I really appreciate your patience in guiding me through this troubleshooting process.

Thanks again!

It’s probably that Lightburn is in inches and your machine is in mm… I fixed the previous post as I thought it was confusing… I think it lead you astray in that it indicated it bassackwards…

As you say, Lightburn and the machine have different units… they need to be in the same units…

When you say Lightburn defaults to inches and the machine is set to mm… that should have been a clue :wink:

Sorry about that… :face_with_spiral_eyes:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.