Neje 2 settings file

I know there are tons of topics on running Lightburn with Neje Master 2 complete with solutions. Problem is that regarding settings file they all point to Northwood and this web site seems to be permanently down.
Lightburn can speak to my Neje Master 2 but there are issues shown up in the control panel. The boundaries are off, the laser emits weird sounds etc. Running Nejes own software works fine.
I would love to have a Lightburn settings file for the Neje Master 2 laser if anyone has a copy? (I assume there are differences between settings file for Neje Master 2 and Neje master 2S?)

In the Console window in LightBurn? Please select, copy and paste the information into a reply here.

If you can communicate with the Neje Master 2 as a GRBL controller you can get the settings out of the controller by typing $$ (followed by Enter) in the Console window in LightBurn. Feel free to select, copy and paste that info here as well.

Here’s what the contents of that report will tell you.

Thank’s for the fast reply!
I’ve set the baud rate to 38400 previously from another post which seems to work.
The $$ command results in the following:



Target buffer size found





































I really do not know (as a novice) if these settings are OK for a NEJE Master 2.

Update: Tried to simply engrave and cut a tag. The laser seemed to respond correctly, moving the head and activating the laser, but regardless of me setting speed and power, the resulting engraving was nonexistent. Seems like default power for the GRBL laser setting is much to low to actually generate anything.

How to change this?

We do see this one often enough to suggest that a look in Device Settings at S-value max may not be set to 1000 ( the same $30=1000) above.

Click Edit, then click Device Settings, you’ll see a pop up with the S-value max that is hopefully responsible for this.

Hi John,
Thank’s for Your advise!
Unfortunately that setting was already set to 1000.

When using Neje’s own software the laser performs well and can cut quite deep (3-4 mm).
When using Lightburn it barely scratches the surface (using 10 mm/s and 100%)
(It cuts down less than a mm in soft wood )
So something else must be at play here.

Any more settings I can test?
( I also run the materials test with 10-30mm/s and 50%-100% intervals with negligable results, barely visible).

note: This Neje 2 is equipped with the standard 7W diod laser)


Ahhh, 10mm/s is 600mm/minute and 30mm/second is 1800mm/minute. Generally folks choose mm/minute for laser diodes.

If the Neje software is using mm/minute you’ll see a substantial difference in the amount of energy that is applied to the workpiece.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.