NEJE Master 2s - A40640 - ALARM 2 - NOT MOVING


So I’ve got an issue that I’m not sure how to fix.

I recently had my machine running the Ortur RYY.

I’ve disconnected that, and reconnected everything as it was to do some engraving, and my machine homes successfully, but when I try to even go frame something in the center of my machine work area, I get an Alarm 2 and my machine doesn’t move.

Any body have any ideas how to fix this?


Here is a read out of the error:
Waiting for connection…

Waiting for connection…

Grbl 1.1f [‘$’ for help]





Target buffer size found






Starting stream


G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)

On or near line 2:

Stream completed in 0:00

[MSG:Reset to continue]


Grbl 1.1f [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

[MSG:Caution: Unlocked]

You probably haven’t set up your machine correctly. This is saying that your machine is being ordered outside of it’s working area. It’s occurring around line 2 or at the start, so it’s probably trying to move the wrong direction.

It is usually how you have it setup in the ‘edit ->device settings’ origin…

I have the same laser, but a different machine.


Thanks for that thought. I tried it moving the origin to every other point returning to bottom left which was what it was before, and it still doesn’t move.

It’s definitely a setting I’m missing, because I opened up the NEJE control software, and it moved and framed the image.

I tried removing the device and re-adding, and it still stays put after it homes and won’t move.
And I’m getting the same error still.

Re-downloaded the original device settings and wrote them to the board via “Machine Settings” and it went back to moving and framing correctly.

Looks like I had “soft limits” set to “true” and that seemed to be the only difference between the original settings and what I had selected.


Great it’s working… However I would have thought it should have worked with soft limits enabled…

Have fun…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.