Neje master 2s homing fail

i haven’t used the 2s for a while, and in the interim the software has moved on

my last available upgrade is 1.2.04, but prior actual work had been done on 1.2.01, which was working fine

i updated to 1.2.04 because trying to use a file created on that version on my desktop machine threw a message suggesting it may not work properly on the older version that is on the laptop that connects the neje in the workshop

the available working size is set at x=170mm, y=155mm, to accommodate a larger laser module (NEJE N40630 laser module) which worked well on these parameters without binding on limits
origin is defined as left front, as previously also
but when i try to have the module move to home, the mount hits the upper left limit


and the following appears in console-

Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.

how do i reset home?

i did it ages ago via console i think, but have long forgotten how, because until now it just worked perfectly

the constant grinding up against the limits on “return to home” is as grating as the sound it makes

help please!

1 Like

If it goes to the right position but does not stop, that is likely a mechanical issue. Bad switch, switch moved, switch actuator moved, broken wire to the switch, or bad connection at the controller board. “Could not find limit switch…” is your clue.

1 Like

so, if i physically press the switch with the laser away from home, should that result in the movement ceasing if i have pressed “home” on the software, as a simple check?

the switch makes a nice “click” when i press it, less so when the stop hits it if i try moving the gantry manually, but it has a nylon pin doing it, versus my finger

the switch and the pin look intact and in place

1 Like

Yes, although in many cases it seems the “thing that should touch the switch while homing” has moved / bent / gotten misaligned just enough to not quite activate the switch.

Your finger is a good first check to see if the switch works, but (assuming it does) you must verify the laser head (or whatever) also pushes the switch.

1 Like

thanks, i figured that bit should follow, but as a lazy first investigation, seemed like a good place to start

the pin to actuate it looks very solid, but my finger makes the “click” happen if i press it; the pin, not so much, although it still makes a noise

thanks for the suggestions

hallelujah jesus ! :heart_eyes:

my finger on the switch stopped the gantry dead, and pushing the actuator peg switchwards a tiny bit made it work also

i repositioned the peg more firmly and now it’s good to go

thanks very much for such a coherent plan - i won’t get caught again by those shenanigans :nerd_face:


Watch out for the other shenanigans too! Glad you are good to go.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.