Neje Master 2S Max with A40640 doesn't want to cut even cardboard Cardboard

Hey everyone,

New to here and lasering in general so reaching out in order to get some information.

I am having trouble getting my Neje Master 2S Max cutting even things as simple as cardboard, even though i’ve had 2 successful engraves using cardboard.

Installed the Neje driver for lightburn from the Homing is fine, orientation is fine, but power seems to be my issue. I went through the common GRBL settings to see if I needed to change S-value Max, but I can’t seem to even be able to tell what GRBL version this board is using to confirm if its 1.1f. I have attached the below images of settings and setup for reference.

Please note that this line was done at 6000mm/min at 80% power



Any advice would be greatly appreciated, especially because getting some drawer organizers cut an assembled this weekend would definitely help me with the wifey.

Thanks in advance

You’re going to need to slow way down. Start at 1000 mm/min. Keep slowing down until you have a good cut.

1 Like

Is that really all I’m missing? These were the device defaults because lightburn was able to detect my laser on first setup

There’s not much to configuration. The main things to look out for in terms of making sure your laser is properly setup in LB:

  1. Working Size is correct and matches to $130,$131 in GRBL configuration (not fully relevant if soft-limits are not used)
  2. Origin - must match expected 0,0 point of laser
  3. S-value max equals value of $30 in GRBL configuration

All these look like they should be correct in your case.

If LB detected your laser it will pickup these values from your configuration (other than origin).

Could you explain how I would go about checking GRBL configuration? It it somewhere in lightburn or do I need something else entirely to check?

Thanks for your help btw.

2 ways to check this:

  1. Go to Edit->Machine Settings. Then push Read. This will read the settings from the controller and present it in a slightly more user friendly way.
  2. In Console if you type $$ and hit enter. It should list all your GRBL configuration.


You’re right, all seems to be in order. Thank you. I’m going to step back the speed and keep the 75% power, see how I do, and report back.