NEJE master 2S Plus 30W

Anybody got good device and machine settings that fully function yet? I’ve done all the latest updates, used all others settings. The best one out there still has lots of issues to me. Here’s what I’ve found that are still issues: (after all updates and flashes as of 4/1/21):

  1. After job completes, machine homes and LR shows all 0’s but when you “get machine coordinates”LR updates to Show machine position as a negative in the”Y” position -440.
  2. Re-running the same job without re-homing, moves the laser about 30mm? farther from home (or the start position of the frame) each subsequent start.
  3. Origin and Home position can never be in the same location no matter what you try. No combination of machine or device settings (including advanced and negative numbers) seems to work that I can find.
  4. I am functioning by unplugging the laser so it will report 0’s, then “getting position” in LR, then starting job. If I need to run another copy of the item, I have to do that all over each time. Ugggg. Sorry for no pics or grbl but I have nothing better than the known setups that have been posted out there which most are good try’s but have many of the same issues. The one posted “response” from NEJE is no longer available and work around have been stuff I’ve already done. Ugggg!

I don’t have a solution but I’m also looking for settings for the same device.

These are my settings which work for me (Neje 2 Plus - 30W). I updated/changed the firmware to GRBL1.1F before using it with Lightburn.

Neje Master 2 Plus - 30W.lbset (5.4 KB)

And my lbdev settings:

    "DeviceList": [
            "DefaultCutList": [
                    "PPI": 0,
                    "angle": 0,
                    "autoBlower": false,
                    "bidir": true,
                    "blowerSpeedOverride": false,
                    "blowerSpeedPercent": 100,
                    "cellsPerInch": 50,
                    "crossHatch": false,
                    "ditherMode": "jarvis",
                    "doOutput": true,
                    "dotMode": false,
                    "dotSpacing": 0,
                    "dotTime": 0,
                    "dpi": 254,
                    "enableCutThroughEnd": false,
                    "enableCutThroughStart": false,
                    "enableLaser1": true,
                    "enableLaser2": false,
                    "enablePPI": false,
                    "endDelay": 0,
                    "floodFill": false,
                    "forceConstantPower": false,
                    "frequency": 20000,
                    "halftoneAngle": 22.5,
                    "hide": false,
                    "index": 1,
                    "interval": 0.10000000149011612,
                    "kerf": 0,
                    "linkDPItoInterval": true,
                    "manualTabs": true,
                    "maxPower": 100,
                    "maxPower2": 20,
                    "minPower": 0,
                    "minPower2": 10,
                    "name": "C01",
                    "numPasses": 1,
                    "overcut": 0,
                    "overrideFrequency": false,
                    "overscan": true,
                    "overscanPercent": 2.5,
                    "perfLen": 0.10000000149011612,
                    "perfSkip": 0.10000000149011612,
                    "perforate": false,
                    "priority": 2,
                    "rampLength": 0,
                    "rampOuter": false,
                    "runBlower": true,
                    "scanOpt": "individual",
                    "skipInnerTabs": false,
                    "speed": 10,
                    "startDelay": 0,
                    "tabCount": -1,
                    "tabCutPower": 0,
                    "tabSize": 0.10000000149011612,
                    "tabSpacing": 0.10000000149011612,
                    "tabsEnabled": false,
                    "tabsUseSpacing": true,
                    "throughPower": 0,
                    "throughPower2": 0,
                    "type": "Image",
                    "zOffset": 0,
                    "zPerPass": 0
            "DefaultToolCutList": [
            "DisplayName": "Neje Master 2 Plus GRBL - 30W",
            "EnableLaser2Offset": false,
            "EnableProcessOffset": false,
            "Height": 440,
            "HomeOnStartup": true,
            "Info": "",
            "Laser2OffsetX": 0,
            "Laser2OffsetY": 0,
            "LastCamera": "",
            "MirrorX": false,
            "MirrorY": false,
            "Name": "GRBL",
            "ProcessOffsetX": 0,
            "ProcessOffsetY": 0,
            "ReverseIntervalCompensation": false,
            "Settings": {
                "AirAssistM7": false,
                "BaudRate": 115200,
                "CommPort": "cu.usbserial-10",
                "EnableBoundsCheck": true,
                "EnableDTR": false,
                "EnableGrblJCommand": true,
                "EnableUserFinish": true,
                "EnableZ": false,
                "EndGCode": "",
                "LaserFire_Enable": false,
                "LastMachineFileExtension": "",
                "LastMachineFilePath": "/Users/oliver/Downloads",
                "NegativeZ": false,
                "OptimizeZ": false,
                "RelativeZOnly": false,
                "S_Scale": 1000,
                "Sim_CornerTolerance": 0.009999999776482582,
                "Sim_FastWhiteScan": true,
                "Sim_FastWhiteScanSpeed": 1500,
                "Sim_GlobalFactor": 1,
                "Sim_MaxAccelX": 800,
                "Sim_MaxAccelY": 800,
                "Sim_MaxSpeedX": 83.30000305175781,
                "Sim_MaxSpeedY": 83.30000305175781,
                "Sim_MinCornerSpeed": 1,
                "Sim_RapidSpeed": 83.30000305175781,
                "Sim_ScanAccelX": 800,
                "Sim_ScanAccelY": 800,
                "Sim_SpeedFactor": 1,
                "SkipWhiteFlag": true,
                "SkipWhiteSpeed": 1500,
                "StartGCode": "",
                "TabPulseWidth": 0.05000000074505806,
                "TransferMode": 0,
                "UseG0ForOverscan": false,
                "UserFinishX": 0,
                "UserFinishY": 440,
                "UserOriginX": 0,
                "UserOriginY": 20,
                "backgroundAdjust": [
            "Type": "Serial",
            "UserCoords": [
                    "IncludeZ": false,
                    "Name": "Middle",
                    "XPos": 122,
                    "YPos": 220,
                    "ZPos": 0
            "Width": 255

Sry this is so long, but, hard to explain. Hope this makes since. Well I tried this and it helped some. But still not there unfortunately. I had to change some things since my connection is USB. Once loaded it homed and showed on the screen correctly and worked. Once I stopped and turned laser back on, it had lost position and showed 440 in home position and position marker on screen was in opposite end now. I then zeroed it out and it worked again kinda. What’s happening is it’s not reading the distance traveled accurately in the 440 direction only. The 225 direction works perfectly. So when you move it to 0 or 440, it’s either a - number or 412, etc. so the only way to get accurate is to home it each time then set LB position to 0. Problem is, the position indicator will show laser at the opposite end from where it actually is. It will always home correctly, but going to origin runs it past its limits. Also I’ll get the curser off the work area so LB and laser are confused and it will actually flip the perceived location of the workspace so it’s working in negative areas off the workspace. Then doing anything is pretty much wrong at that point so reset is necessary. IN SUMMARY, I think it might have something to do with USB since this works on serial. If I could re-calibrate the 440mm direction to be accurate, that might fix it. I need to understand why it starts out with location of origin for all in the same place and laser shows 0 in home position, but once I do anything job wise and it goes to home, it shows curser at opposite (actual) home position AND 440 as position.

Olli where do you load the .lbset file?

have you uploaded the neje_grbl_uploader_v34 file firmware from there wiki.nejetool page,if you do that all settings are correct then and start then in lightburn with settings right under at ablosute cordinates.

1 Like

Hello, wich option do I have to use while the firmware update? There are 3 Options.

For me the first one worked.

Hello everyone, I also have a master2s plus 30W. Would be happy if someone would share with me his experience. Have yesterday for the first time laisert. Have cut 3.7mm plywood with air assist 200 feed 90% power 2 passes. has worked great!

Sounds to me like you’re rockin’ and rollin’!

Do you have tips for engraving pictures? Settings?

I have the same and for engraving, I use a test chart for reference for each type of wood. There are several out there you can find. I save the test piece of wood so I can reference it when I’m starting a new job. Hope this helps :slightly_smiling_face:

In my case I’ve only done tiles with it so far and I’ve posted those details elsewhere. It’s currently packed up to bring to our Summer home. There I’ll install the air assist, etc…

I have air assist. It does help for both cutting and cleaner engraving

Something familiar is happening to me. I have Neje master 2S Plus 40W but when I start lightburn current position is ok in both axis, once I move on Y axis (from 0,0 or home) the current positions changes to 425 and it only lets me move 10mm because it displays I’m off working area. Did you find a solution for your problem or can someone help me?

No real good answer because I’ve got into the habit of going to the move tab and checking before I start a job. If it says anything other than 0,0, I turn my laser off and back on which 0’s it out to match. Then run as usual. However, mine says 12.35 or something like that when I home it. Haven’t had the time until today to ask the pros here why. Lol