New computer, no laser connection

I have a Boss 1420. it was auto detecting fine on my windows 7 PC, but that took a crap. Now when i try to find it on the windows 10 PC, i cant find it. I have tried reinstalling the BOSS driver but it does not seem like it is changing the name in device manager. Still just says “USB port”.

Any help is appreciated.

If Boss is a normal Ruida, the drivers here should also work:

Sorry to hear you are having issues with ‘Find my Laser’. Have you tried to set up a profile manually using ‘Devices’->‘Create Manually’, and then choose ‘Ruida’ and complete the process providing the other required information?


yes, i did. Just couldnt figure out why it would not recognize it on the newer one.

as far as the driver, windows says the generic one is best. is there a way to force it to take my driver?

Can you show a screen shot of the port in Windows? If it’s a COM port it should be ok. If it’s showing up with a warning symbol, that’s more of an issue.

Yea, tomorrow. There is no warning and it is showing up as COM6. It works fine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.