New laser just flashing

Last night I used my new laser from laser tree. It’s an 80w. Today I moved the laser machine to a new location and when I powered it on the laser just started flashing. I did have to buy an extra part to connect the wires which stated I might need to use an additional power supply. I added the additional power supply and now the laser is on constantly and will burn on every movement destroying what ever project I’m doing. I don’t believe I need the additional power as it worked last night with out it but why is it flashing me.

I would guess that there is some problem with the modifications you made for the other power supply.

We’d have to see some pictures and know what laser module, control board you have and how it’s wired.

I’d try restoring it to it’s original state if possible.

The laser module only needs power, ground and a pwm signal to control it… I’d venture to think you crossed up something to the laser module.


Thank you for your reply. I added the additional power after as the the model I needed to use for the requires it if there laser is a 24v but mines a 12v

Can you put it back like it was? If you don’t need the extra power there’s not much point?


I’ve tried and it just flashes at me

Did you switch it to external power?

I can see the pwm connector but can’t read it.


I did then it stops the flashing but then when I run it it just runs on power mode and leaves lines through all the work I do. Like it doesn’t power off at all and it doesn’t go to full power.

While last night I made that within 3 minutes and now it just won’t even cut through the mdf

Thank you for your help tho.

Do you have $32 set to 1?


Not sure I understand what that means.

Grbl usually has settings designated by the dollar sign and a number…

I assumed you have a grbl based machine, but I could be mistaken…

You can go to the lightburn console and enter $$ it should output all the values.


Oh I see what you mean. I’m not to sure as when I turned the laser back on it wasn’t connected to the laptop. I will try and find that and check it out. I do appreciate your help tho.