New MG3 board in a 60watt Laser

Hi I am at my whit’s end…I have a 60watt CO2 laser and installed an Awesome.tech MG3 board on it _great board works great with Lightburn for engravings, but i cant seem to cut through 3mm and 6mm mdf like i use to with the M2 nano board. For instance i cut a 20mm square as a test cut, the laser cuts three sides perfect but the last side in only cuts half way through the 3mm wood… same for the 6mm mdf. what am i missing here is it a setting in LightBurn or what can it be?

I don’t know the answer to this, but try the Awesome.Tech forum. They are so helpful! I also have a mg3board.

Has this ever been fully functional?

It looks like it’s connected to the laser the same as a Ruida, from the Awesome.tech site.

This sounds more like an alignment issue, including the beam path. Although it’s a relatively small change for the head, which is contraindicated for alignment issues…

These are relatively simple in that if the tube works and fires, it’s aligned correctly and it’s focused they work. Something is happening in the area or at the last side.

If you cut the ‘box’ in the other way, does it fail in the same area or same part of the artwork.?

I would think the controller most likely is not failing on the last line.


The interface from the controller to the lps is pretty simple. These would be easy to check with a voltmeter.

‘Laser on’ is apparently working, since it’s firing correctly.

You can check the pwm output to ensure it isn’t changing when it does the last segment of the ‘box’. That should be relatively simple. That would eliminate the controller and probably the lps/tube.

Do you see a current change when it fails on that line…?

:smile_cat:

Morning Jack,

It definitely can not be alignment issues because the M2 Nano cut all the way through all of the sides at halve the percentage needed with the MG3. Don’t get me wrong, the MG3 is a great piece of tech. Just the engraving with that little board is 1000% better than the M2 Nano can dream of achieving. But it’s like when it comes to cutting something is weird it’s like the machine is cutting tabs, but on the whole 1 side? Now I must be honest, I have the board on a 60 watt laser and it has 3 power supplies… a 5 volt, a 24 volt and the main laser supply… the 5 volt supply runs the limit switches and laser dot (red dot) and the 24volt is for the controller… and then the main supply for the tube… the tab settings in LightBurn is switched off - is there a setting somewhere i am missing? I am pretty new to lightburn

I know of no option that can cause 3 sides of a square to work and the last fail.

I doubt it’s a controller issue or Lightburn. If the artwork is not simple, that could raise a question, but a square is not highly technical to draw…


I suggested a simple diagnostic, check the pwm for proper functioning… That will tell you if it’s getting a different signal on that side. That simple test would confirm or eliminate everything ‘upstream’ of the lps.

Does it happen on a certain side of the square consistently.?

What if you change the direction of the cut?


Some don’t answer questions because they don’t understand what’s being asked or the procedure to get the requested results. Speak up if this is a problem… Or we’ll both be spinning our wheels… Knowledge is not received via osmosis, especially via a forum…

Good luck

:smile_cat:

Hi Jack,

yes a square is really not a technical thing to cut, yes the side not being cut through is always the same side (and here comes the kicker) unless I change the direction of cut. In other words if I set the direction to start at the top left of the square it will go down then right then up and when it comes left it wont cut the whole way through. but when I change the direction to start and the bottom right it will go left then up then right and when it comes down it wont cut through the last leg all the way… It seems like the last quarter to a third of any shape I cut it only cuts half way through the MDF, doesn’t matter if it is 3mm or 6mm MDF same result. If I put back the M2 Nano board and use whisperer with it no problem cuts the whole design like a hot knife through butter. Lets say I cut out a circle ( supposed to be a full cut out of a circle inside of a square it wont cut either through

I thought the MG3 wired up to the lps a bit differently than the normal K40 does. Did you make a wiring change… Don’t know about this personally, but my ‘reading’ indicates they are different.


It sounds like the pwm isn’t translating correctly. With grbl the values have to be set to certain values to ensure the controller has the best range for it’s pwm. How it would change as it’s doing an object escapes me.

On the MG3 I don’t know what you can change to correct this, but for some reason it hits me as a configuration issue, unless the hardware is broken… that doesn’t make sense either.

I’d target the MG3 configuration and find someone with knowledge about it.

I sounds more like software (firmware configuration), as you demonstrated it’s board specific and we know that board works for other people.

That leads back to configuration of the MG3 board.

:smile_cat:

1 Like

Like I said before, have you directed this issue to the people at AwesomeTech? I have found them willing to bend over backwards to help.

We need you to help us fix your problem. We need you to answer the questions posed.
Re-read post 5s last comment.

  1. did you measure the pwm as suggested in post 5?
  2. what is controlling the K connections on the lps?
  3. assume this has never worked, same problem?

I don’t think we have gained any ground here…


I went to awesome tech site to find the manual. For a manual, it linked me to a Facebook page with no mention of a manual and everything there was ‘private’.

You are going to have to come up with the documentation for us to help.

:smile_cat:

I would first look at your PWM frequency settings between your MG2 and MG3. I forget what’s best for which but PWM frequency can greatly effect cutting and engraving oppositely.

As for closing the square, if you created the square using the LightBurn basic shape then it’s a closed square and since it worked fine with MG2 then it’s likely a GRBL setting. Why don’t you plug in your MG2 into a USB port(power it up), connect LightBurn or any terminal app to it and save the GRBL settings( using $$ ). Then do the same with your MG3 and look at your settings. I would look at your acceleration settings but do a line by line comparison and you should find your difference.

Hi Jack and Doug

sorry I haven’t replied yet. I had to put the M2 Nano back to do some orders and didn’t get time to put the MG3 back yet to do the testing. I will let you know in the next couple of days what the measurements is, i just have to get these orders out.

thank you for all the help so far its much appreciated

1 Like