New OMTech FM2435-30 doesn't fire

Hey there. We purchased the OMTech FM2435-30 this winter and I finally got it unpacked and am attempting to get it going. It seems like everything functions … except the laser!

I have everything assembled, checked for loose wires, installed the software, and when I try to run a program, the laser moves on the gantry, but no laser output whatsoever. I have played with focus, etc and cannot get anything.

I notice that when I turn the machine on, push the “Control Switch”, the green light comes on, and when I turn the Laser Switch, the red light indicating power to the power supply comes on, but there’s no extra noise, or click, or anything.

I have experience running a Keyence and there was always a long “loading” time while waiting for the laser to actually be “ready” and it ended with a loud metallic click when it was ready. Nothing like that here…is it really ready the instant I turn the key?

It’s in the garage, and the garage has no heat. I have tried it cold, around 30 degrees, and I have warmed it up using an ice house heater to around 60 degrees, but it’s sure possible that the laser was never that warm, as it is steel and lower to the ground. Today I am running the heater all day to see if it warms up and acts differently.

I’m flummoxed. I engaged with OMTech tech support immediately and we are exchanging 1 email per day :frowning: and so far it has been very basic (send me a video to prove that you plugged it in to the wall).

I’m hopeful that someone has run into something similar. My main concern is that most of the tables from OMTech are for CO2 lasers…this is a new entry to their market and I believe one of the first to have a fiber laser. Most of the resources online are related to the CO2 laser.

I’ve heard the Facebook group is good but not checked there yet. I’m hopeful I just have a fuse or missed connection or something simple! Any help would be super appreciated as I have a job due in a few days that doesn’t seem very likely right now…

I’ve never seen one of these or it’s innards… Could you post a photo?

I know a little about fiber, but I’ve only see inside of a galvo type, not a moving head type.

I’m curious how the fiber laser system is controlled… with the fiber machines I’ve seen, they move the mirrors not the gantry/head, so I don’t know how the Ruida controls the fiber laser… the gantry/head maybe…


The Ruida has two outputs for laser control, the LPWM1 is the pwm that is generally wired to the IN of the lps and L-On1 which is wired to L on the lps.

This is a co2 lps connections…


If you can post some pictures it would be educational for all of us that don’t have one…

Probably a faster response than the 24 hour turn around associated with people on the other side of the planet… probably someone here has one or knows about them.

:smile_cat:

Thanks a million. Happy to show pictures or videos of whatever you think will help.

US-based customer support was a big selling point for me… :smiley: should have investigated THAT one a little more.

Below are photos, let me know what else I can take a picture of to help. I also have videos showing the problem that I’ve been sending OMTech. Basically showing the steps I take to turn it on and then the lack of laser. Not sure the best way to share those here. Let me know if there’s something else I should take pictures of.

I warmed up the garage today and no dice. Still had no output.

I would wonder if my program just sucks somehow, if I’m still learning Lightburn, but I can’t get it to pulse or anything manually on the Ruida control, either. I was going to watch another tutorial for LB to see if I could learn anything.

It’s like there’s just a fuse or a bad connection somewhere…I took off the lens last night to check for an obstuction/lens cap.




Somewhat off-topic: a plastic razor knife can remove the protective paper from the hatch without scarring it for life:

Yeah, plastic razor blades. Who knew? :grin:

That’s amazing, thanks. I’ll definitely grab a couple of those. Thank you! My hope was to get the laser running before working about the cosmetics :thinking:

Do you know what the green board on the upper right is for or where the white cable on it goes?

I’m suspicious that is the Raycus interface ?

The Ruida must be triggering the Raycus with it’s laser enable/pwm… I’d guess. I don’t know what control signals are available on the Raycus fiber… Actually haven’t looked at either…

Do you know the model number of the Racus? Trying to find the proper manual … found one… don’t know what you have…

This is the laser controls out of the Ruida… Follow this group. On the standard lps, L-On1 is the laser enable and will go low when active. The LPWM1 is the pwm (percentage power) output and is usually wired to IN of the lps which is the power control input.

PWM on the Ruida runs as soon as you press ‘start’. L-On1 tells the machine when to fire.

Have you tried re-seating all the connectors from beginning to end, I.E. the Ruida → green board (?) → Raycus? These are the outputs from the Ruida.

Thanks for the photos

:smile_cat:

Did you get this to run correctly? If so, please enlighten us…

Edit: Do you have a way to set the laser source in the Device Settings?

:smile_cat:

Hey! So sorry…

You posted your helpful response on Thursday of last week. I didn’t get out there Thursday or Friday to troubleshoot, got the garage heater installed Saturday, and finally got down to business on Sunday.

Between your advice, and the latest OMTech email asking if the fan was running on the laser, I focused on the power supply. Even though I showed them a picture of the fan not running in the PS, they insisted it worked fine. Using your advice, Jack, I started following wires. The multimeter showed no power input to the PS, so I started chasing those wires through the machine, back to the Laser Switch on top.

I fiddled with those wires, and eventually heard a new sound! Even though the laser was powered down, fiddling with the wires made the laser fan come on, a sound I had certainly never heard!

It worked intermittently after that, eventually working much better after I reseated all the wires on the switch, took it apart and put it back together tighter.

However, yesterday in the cold it didn’t work again and I had to repeat the process.

Seems a work in progress but at least I seem to have a source of issues and a solution.

I really appreciate your help! What a relief.

We’d like to see you up and running… not limping along…

Speak up if you still need some help …

My new laser is on the truck for delivery… we both have new machines… :smile_cat:

:smile_cat: