New Ruida controller ignores my Lightburn speed and power settings while running a job

Hello, I recently installed a new Ruida RDC6442S-B into a Full Spectrum Pro-Series 36X24 laser. (The original FS controller died). I’m using a Windows 11 PC.

I am able to run jobs on the laser, but I am not able to control the power or speed. Regardless of the speed and power settings I enter in the Cuts/Layers window, the laser always runs at a very slow speed (I would guess about 30 mm/s), and the same power level (If I tell it to run at 2% or 100% the results are the same).

My guess is that this is a software issue rather than a wiring issue. If a wiring mistake was the problem I would expect only speed or power to be an issue, not both? Just my Hypothesis.

I am able to access the manufacturer settings within Lightburn by entering the password RD8888, I will be prompted that the settings were transferred to the laser. But then if I read the laser settings again, they are reverted back to the original settings. I’ve also tried entering the admin password directly on the laser controller, but I get an error code every time (I’ve tried multiple iterations of the manufacturer password with the same luck).

I think I’ve concluded there is some sort of mismatch between Lightburn and the controller. Any ideas for remedies?

Thank you,
Andrew

Lets take one thing at a time… I use lps term for the laser power supply or the hv supply for the tube.

Lightburn doesn’t need a password… I’m assuming you are doing this on the machines console?

What were you attempting to change?

Did you save the settings of the previous controller?

How do you know it’s the same? Some kind of indicator, like a mA meter?


How is the Ruida wired to the lps? The main wires (Ruida → LPS) are the laser enable (L-On1 → L) and the other is pwm (LPWM1 → IN).

Usually P is grounded on the lps, this is the water protect… the Ruida usually handles this if wired correctly.

Do you have a voltmeter? You can measure the pwm voltage and see if the Ruida is creating the proper pwm…

:smile_cat:

Thanks for the response Jack.

When you read the lasers controller settings from lightburn you’ll get a basic list, and then you can type in the password to get advanced settings. But regardless, if I try to change any of the settings and write it to the controller, lightburn prompts a successful write. But then if I read in the lasers settings again, they are unchanged. I tried entering RD8888 on the machines console to look through the settings, but I would get an error message and denied access. The same password works within Lightburn.

I was attempting to change the max speed and max acceleration settings to see if I could make anything change, but no luck getting a change to go through. Jogging the machine from Lightburn and the control panel will run at an appropriate speed though.

Yes I have a mA meter on the laser, it maxes at approximately the half way point on the dial (I believe around 25 or 30 mA).

Unfortunately I do not have settings from the previous controller. It was dead before I ever had access to the machine.

Double checked the wiring you described, it is correct.

I have never seen a password prompt in Lightburn and I’ve used it almost 3 years…

If you click on Edit → Machine settings… do you get that?

What are your acceleration and maximum speed settings for the machine?

How fast are you going?

Might be smart to tackle the power issue then move on… Do you have a voltmeter?

You can set the power on the console and duration to continuous, hold the key down and measure the voltage either at LPWM1 or at the lps IN terminal. No need to power up the lps, it would be wise not to.

The LPWM1 or IN should read whatever percentage you set applied to 5V. If you set 50% pwm (power) the value should be 50% of 5V or 2.5V… 20% of 5V results in 1V.

This will tell you if the controller is sending the correct control to the lps, hopefully, eliminating the controller.

:smile_cat:

I don’t think this really matters for this particular problem, but to get to manufacturer settings (requiring a password) - Edit>Machine Settings>scroll down and expand Vendor settings, this is when I was prompted for the controller manufacturer password. I would have described it better before if I had been on my lightburn computer.

But thank you for the advice on measuring the power input. I will try that out next week when I have access to the machine again. I’ll be back with my results.

Thank you!

Mine has never done that when going to the Machine settings… It may be that the password you supplied is not correct.

The Ruida isn’t too smart and I don’t know if it always can tell if the upload is successful.


I suggest using Ethernet rather than usb, it’s much more functional and dependable. This would help to ensure a more dependable transfer.

It’s relatively simple to plug it into your local lan.

:smile_cat: