New to Lasers. Laser not cutting. GRBL 1.1 Shapeoko XXL

I just bought a new endurance laser 10 watt Laser. I thought the problem was the Laser itself. (still might be) but at the last minuet i decided to check the output from the Grbl board. I found that when i try to run the file set with Max output at 100 or what ever i get 0 volts. If i go to the move button in the software and push the fire button at 20% then i get 1.5v. if i lower the percentage then the voltage adjust down accordingly. So that tells me that the software is not giving me power and that my board is not bad or i would get no voltage at all when i push the fire button. I am sure i just missed something as i have never used a laser before. any help would be greatly appreciated. Thanks!

What settings are you using for this cut? If you’re using GRBL 1.1f and you try to move faster than the controller is set to allow, it will scale down the power to compensate.

500mm at 100% I have the wires from my grbl pwm output going to my meter so i can see the output.

500mm … per second? per minute?

Im sorry, i didnt see a way to change that in the cut settings Editor 500 mm/min i thought min. was the default.

The ‘Units’ used in LightBurn can be changed in the ‘Settings’ window by clicking the ‘Gears’ icon near the top-center of LightBurn screen.


You can also toggle from using Metric and Imperial units from this control also found top-center of the main screen. image

ahhh I remember that during setup. i have it set to mm/min. i may change that to inches/min later after i get this working. but still i have no output signal during the actual engraving cycle.

To confirm, what version of firmware are you using and what are those settings? Type “$$” into the console and hit ‘Return’. Please Copy and paste the entirety of what get spit out here for review.




Thanks was an extra! :blush:

When you connect to the controller, it should tell you which version of the firmware you’re running. (GRBL 1.1f or later is ideal)

grbl 1.1 I got it last March. The CNC machine. just got the Laser

1 dot 1 what? :wink: Is there a letter after the numbers?

I just saw this error when i reconnected

Grbl 1.1f [’$’ for help]

[MSG:’$H’|’$X’ to unlock]


[MSG:Caution: Unlocked]


GRBL error 9 is a homing error. That likely means you have homing enabled, but it’s not working. That shouldn’t affect the output of the laser though.

ok thanks on the homing error. any thoughts on the other? maybe still working on it?

I can’t see anything in your firmware settings that is incorrect, and nothing in what you’ve said sounds wrong. If you can post the LightBurn file, or a screen shot of the settings you used, perhaps we’ll spot something, but so far I see no reason it shouldn’t work.

Hello World.lbrn (28.0 KB)

I don’t see anything strange here.

Try this
Open the console, then type the following commands (note that this is going to fire the laser, so have material under it and wear safety glasses)

G0 X0 Y0
G1 X10 F1000 S500

If you don’t get 50% power output from that, there’s likely something wrong with the laser or physical connection.

I too have an XXL and in order for mine to work I created two macro’s:

;Laser Mode

G10 L2 P1 x-812 Y-812

;CNC Mode

G10 L2 P1 X0 Y0


Also goto Edit - Device Settings and at the bottom right of screen S-Max = 255