New User, Xtool D1 frames project correctly then runs into limit

Hello lightburn users, i’m a new guy stuck with a frustrating problem. I have a PC, using latest lightburn, and have a new xtool d1 pro 2.0 10W. I’ve made a couple successful cuts and engravings and started a new project using much of the work space. I set the project to absolute coordinates and had the head start from home (top left). It correctly framed the project in the workspace and matched what the preview showed. Halfway through cutting, after engraving, it moved to the left most position and stopped with an error–i believe it hit the left most limit (home position is left rear). I’m not sure how to trouble shoot this and would appreciate any help. I tried moving the project and starting over, it would frame correctly then move more left and cut off material, or left and hit a limit and stop. Each time it moves to the left it is a movement not shown in the preview and out of the area framed at the beginning.

I am having same issue after installing software on a new computer. Frames up fine, but when start it immediately runs off to side out of limits.

When you look at the preview in Lightburn, do you have Show Transversal Moves selected? If you do, you should see red going across your image. That shows you how far the laser is actually moving. You will probably see that it goes beyond your image because of overscanning, which is where the laser goes slightly beyond the image before reversing direction. It gives the laser time to accelerate or decelerate without excessive burning at one point. If your project is right on the edge of the XTool’s working area, the limit switch can be bumped. You can set the overscanning percentage in the layer settings box.

project is considerably smaller than workspace. good 4-5" all around. So thats not it.

My preview did show traversal mode and the red line did not show the laser moving in that direction. Also, the problem occurred during the cut stage and not during engrave when it was overscanning. Thanks for the suggestion and for trying to help.

I searched forums more and I think I resolved the issue. The xtool has an offset for the laser crosshairs. I went to device settings and disabled this (see below). Then is went to the cut and did everything right. I think what was happening was it framed it using the laser cross hairs, then when it tried to move over to the work area it was using the cutter position and adjusted the whole thing left, hitting the limit or missing the work area. What a pain! Now that I know this, i’m wondering if I should swtich the offset back on and use the crosshairs or instead use the laser fire button for framing and positioning. I knew there was an offset between the cross hairs and the laser but didn’t realize it took this all into account. Thanks for helping everyone and good luck Jason!

1 Like