Newbie Can't figure out what changed

All right I have a CNC3-3018Pro MCWDOIT and I converted to laser 15w 450nm. Been having the time of my life until I temporally hooked up the Genmitsu Rotary Roller Engraving Module. Since going back to the y axis table it seems no matter what I set change, etc. Nothing will burn right because my Y axis table doesn’t move in time with the laser, so it just burns back and forth instead of etching the image. Now I’ve even reset Lightburn 1.0.06 running on a win 10 pro machine, and nothing seems to bring it back to when it was working flawlessly. Can Anybody help PLEASE!!!

I have a similar animal.

If you know the type of control board, it’s nice to know.

What probably happened is probably went something like this… that you hooked up the rotary. You had to change some configuration information to get it to operate. Great, works…

Go back to no rotary and it the machine doesn’t work correctly.

This is a common ‘goof’. Before you touch anything, especially a machines configuration, save a ‘factory fresh’ backup of the settings.

I really wish they would note this to users when they get a rotary. It would only take one line of warning.

From the ‘Edit → Machine Settings’ you can ‘save’ a copy of the current configuration. Name it something ‘factory’ like or whatever…

When the rotary is working, ‘save’ the current configuration. Name it something that is ‘rotary’ like…

Re-‘load’ the original and ‘write’ it to the controller and you would be golden…

If you have a vendor that is responsive they might be able to supply them. I can give you a copy of mine, but it’s configured for a CNC (has a spindle on it currently.) This machine has never had a laser on it, so it isn’t going to work, in all probability, but it might give you a place to start.

This is a very stock, Vevor CNC 3018 Pro with limit switches. So it will have to be configured for a laser.

I cringe about you just ‘loading’ this on your machine as I don’t have a clue if you would be ahead or not… You could save the current one, then load mine…


This is the stock setup, which had the Z axes going the wrong direction for a proper ‘home’.

Good luck.


Controller Grbl 1.1

Thanks for quick response yea my controller is grbl 1.1 and I sometimes use grbl laser software that comes with grbl. Little curious why no laser for you?? I started out with spindle and can covert back. Got this as a Christmas gift from my granddaughter. I’m loving it so far big time learning curve. I’ll download your files and go check and see if I can find original. Thanks again

I do, I have been using the co2 laser and the CNC for making pcb’s. I had one of my other CNC machines running an led laser. Kind of moved on…

‘China Blue’ 50 watt 5030

Good luck


Ok tried loading your file no go, tried reflashing GRBL and that was no help, I’ve reset and played with so many files I’m crazy. LOL
Bottom line should I get a replacement GRBL Board and reinstall everything. Lightburn will reset.

I’ll be here a month of Sundy’s trying to figure what happened. Well if nothing else I learned to back everything up before exploring. LMAO. Any other sugestions???

You said this happened right after connecting your rotary?

What are all the steps involved in setting up your rotary? Please list them.

Do you need to unplug/plug anything? If you are missing Y-axis movement sounds like it could be more physical/electrical than something in your settings. Try double-checking all your connections.

Do you have access to a meter? Can you check the signal out of your controller on the Y-axis? Are you getting any signals?

Unless you fried something I’m sure there’s a way of fixing your current controller. But will likely need to take it back to basics and test one thing at a time.

Thanks for your response. the proceedure is quit simple you plug a wire provided by Genmitsu into your Y axis and then go into program and enable the roller. That’s it I tested the roller and unpluged it and pluged in the y axis since then everything seems to work except the y axis. However note that when I use move the table moves back and forth but not when I use the laser.???

Okay so I took tthe wire off Y axis motor and put the ol ohm meter to it while it was running it jumped from 24.04 volts down to .34 volts ???

So you’re saying the Y-axis does move with the jogging controls? If so, then this is likely just a configuration issue but the symptoms are odd.

You’re saying it was 24V when not running? I assume it was actually being instructed to “hold” position. How did you cause it to run? Did you use jogging or run a different operation?

Can you try switching the wires from Y stepper to X stepper? Does the fault stay with the motor or move with the wire?

First let me say Thank you all for your fast responses and help. However, problem is solved the Y axis on the controller board has been fried. I proved this two ways, one being I simply hooked up the roller again, and plugged X axis wire into Y axis stepper motor. Well needless to say Sparky has done it again. Ordered new board and will note all lessons learned. Again, Thanks so much.

Unfortunate. The question then is why? From your description you weren’t doing anything outside of expected norms. Not sure how you’ve avoid this the next time.

Is your rotary the one sold by the manufacturer as being compatible? Perhaps the manufacturer could provide some insight. And offer a free replacement if still under warranty.

No, I get stuck on stupid and fail to turn the power off for some unknown reason. I’m a ham radio operator and have dabbled in electronics for a while now and I still have a problem with turning chit off when working on it. That is how I got the nick name Sparky. LOL My bad and will try to do better. :innocent: :innocent: :sunglasses: :sunglasses:

Well, just don’t get yourself hurt. :laughing:

:crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face:

Some of these Chinese configurations are pretty strange.

My first one was a Woodpecker grbl board and I hooked my scope up to the motor and smoked it…

Seems the motor negative isn’t really ‘ground’ I’ve also had some 100v power supplies that had a 40v potential between it’s ground and that of my house and other equipment.

I always check them now…

If you don’t power this stuff down, Amazon will love you, keep replacing parts… :crazy_face:

Did you order a replacement from Amazon or similar or from the manufacturer?

You will be back in the same boat as far as not knowing how to configure it… :frowning:

My fried grbl is kept around for a pwm generator… that part of it still works…

Take care

73’s de KA7CMF


Okay, back up and running and here is the thing, GRBL laser program is running just fine with laser firing no adjustments. Get into lightburn and nothing everything moves but laser is very weak. adjusted speed to 1000 and 100% fire and laser is barely burning the plywood???

Can you confirm that the units that you’ve used are what you expect? You’re listing 1000 but no mention of units. I suspect you’re using mm/s but are expecting mm/min. This would cause a difference in performance.

yes sorrry about that, Speed changed from 6000 to 1000 mm/n, Power 100% did this in the Cut/Layers menu under 00 Black.

Just to confirm… you used 1000 mm/m @100% power on both LightBurn and LaserGRBL and got dramatically different results? The only additional factor there should be whether or not you have “Constant Power” mode set in LightBurn for the cut layer which would make it identical to LaserGRBL. The results will be different but not dramatically so.

Check one thing. Compare the value of $30 in your GRBL configuration vs the value of S Value Max in Device settings. $30 should be either 255 or 1000. Change S Value max to the value in $30.

I don’t think this would have caused the issue you’re seeing though since if anything you should be burning with more power than expected.

In either case, for your laser setup 1000 mm/m would be very fast for a cutting operation. Could work for some engraving operations. Don’t know what you’re working with at the moment.

Well let me just say that from what I see so far, each program mirrors each other’s settings. At least that is what is happening on my computer. With that being $30 is set at 1000 as well as S value. Lasergrbl will fire up my laser and do an image that I open and Lightburn doesn’t.??? :nauseated_face: :nauseated_face: :nauseated_face: