Newbie fill problem

Hi to all, I’m new to lightburn so maybe this is stupid question but i have tried all fill and optimize options
and i still cant get what i need.
I’m not so good at explaining things but i’ll try(GIF will explain)
I am using an eleksmaker chinese clone with GRBL controller and diode laser so my cut/fill speeds are 500-2000mm/min. So basically i want to be able to fill shapes in one pass of the laser as the 60000 speed example shows but with speeds 500-2000, the 1000 speed example show what i got but dont want. Hope you can understand me and thanx for answers.
https://drive.google.com/file/d/1sRy9W3l1I0ycQvR31ODctg04TtTp1W_F/view?usp=sharing

Hi Daniel, select the ‘optimize cut path’ in your ‘laser’ window.
In the ‘cuts/layers’ window select ‘fill all shapes at once’.
Hopefully that’s what you’re after.

In the ‘Cut Settings Editor’ ‘Advanced’ tab, do you happen to have ‘Flood Fill’ turned On (green) by chance?