Newbie made a mistake

Is this going to be a dedicated laser solution for you or are you planning to swap to 3d-printing and/or other things?

If this is dedicated, you may want to switch to a GRBL firmware as that’s going to be much more widely supported and likely more functional. Granted I’ve never done this mod so take it with a grain of salt. Looks like grblHAL might support the controller.

Yup Just was not sure if this program would work right on a 3d printer. I can now home it but there is no other control other than the laser.And the printer is throwing temp errors. So LB gcode is not working with the print version of Marlin that is on it. Try to figure out how to setup grblhal…

If you want to 3d print things, Lightburn is not the program for that.

If you have your ‘3d printer’ set up with a laser it will work fine.


Ok made a work around for the temp error by adding M302 S0 To the start gcode. Now LightBurn can run the gcode. Need to figure out why it wanted to do a homing on start.

Probably set to do that. $22 is set to home, it will lock out all commands until a home is completed.

Check it in ‘Edit → Machine Settings’. While there save a copy of your configuration…


Did not see anything for homing. There is all of my ABL 3d printing probe locations saved I might just need to compile a Marlin for laser work and just flash back and forth when needed. Thanks for the help…

Trying to set up the printer to do both.

I suspect there’s a Marlin configuration for homing that you’ll need to change. In addition, LightBurn has an option to “auto-home” when LightBurn connects. You can turn this off if you don’t want it.

Auto home is turned off.

Probably a configuration in Marlin then.

Did you check $22?


That’s a fact! :+1:

@jkwilborn, I think $22 is only going to be on GRBL controllers. Don’t think that exists in Marlin.

Sorry, thought the Marlin was another grbl machine.


G28 is homing for Marlin

Probably would have been easier for @DarylPe in this case if this had been grbl.

Founds this, “changed the baud rate in settings to lowest, closed program then reopened the program and it connected! So far all I have tried is homing from laser control and it works”

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.