Newbie made a mistake

Hello all. I bought a copy of Lightburn before trying it out to see if it can work with my Biqu B1 printer and Solvo laser. I have tried to setup the device as Marlin and it says ready but I have no control over the printer so the codes must be different. Does anyone know what I need to do to get LightBurn to work with the printer running Marlin?

Can you elaborate what this mean? What are you describing as being ready and what does it mean that you have no control? As much detail as what you’re seeing/hearing/experiencing would be helpful.

Please take screenshots of the LightBurn application main screen, the device settings screen, and any content in the Console window (usually a tab in the top right pane). Then post here.

Here is Lightburn running with my Biqu B1 turned on and connected to the PC. I can not control the printer laser through LightBurn. Other programs like Cura and Pointerface can control it Even LaserWeb has control of it.

If you need anything else let me know.

It is running Marlin

In this ‘move’ window, can you ‘jog’ (move) any of the axes?

It thinks you are connected. Go to ‘Window’ and enable the ‘Console’. It will have a tab like the ‘move’ tab. That will show some of the commands and responses from the controller.

Open it and reset the controller so we can see all the information is puts out at startup… This will be information such as the version of the firmware on the controller. It will also show other errors that may occur. A screenshot is helpful…

Does your machine ‘home’ by itself on power up?


This printer is not set to home after power up. It is in the Start G-code.
Getting a stream of G0…

Definitely having a connection issue. This looks like it thinks it sees it but can’t talk…

Is that all you get if you reset it with the console open…

Might browse this area


Ok will do… Thanks

You can ‘search’ the site with the magnifying glass…

Is that all you get from the console if you reset the controller with it open?

Is there a baud rate you can set???

Sorry not a windows person…


Wow found a thread with the same problem. Ran Pointerface let it connect. Closed Pointerface loaded LightBurn and now its talking.

I was about to ask if you had something else potentially holding the port. Glad you found it.
Does this mean you’re up and running now?

Great. If that fixes it, mark it solved…

Good luck, have fun…


I have control now. Just need to learn this program LOL

IMHO all of us are still ‘learning’ this program… You will not regret using Lightburn, it’s the best available.

Lots of videos and great help here…



I need to figure this out now.

Don’t know that board, but looks like it’s a temperature problem. Might search for that error…


Yup more to figure out. Heck something to do… :rofl:

It’s a learning game. Just hang in there…

Soon you will be answering other peoples questions…