Newby needs a lot of help

A while back, I purchased a digital K-40.
Instead of testing it as it came out of the box (as I should have) I immediately started installing all the suggested safety equipment and analog amp meter, that I saw on YouTube.

I also removed the stock bed clamp and cut back the exhaust vent.

This K-30 has a ribbon cable and a wires/plug for the Y axis.

The computer (actually 3 different Win 10 computers and one XP) wouldn’t recognize the M2 board through K40 Whisperer or Windows Explore.

USB cable is proven.

When I fired it up it would sometimes “home” (sometimes not) and always chattered loudly at the end of travel.

I ordered and installed a Cohesion3d replacement board and LightBurn software.
Now, upon powering up, I get all five LEDs to light with two flashing green and the computer recognizes the board.

Now the laser head moves to the lower left, but still chatters.

Nothing else works except the laser test and all the meters.
I’ve tried the “Move” buttons and laser location on the drawing and tried to get it to cut a line.
No Luck !!

It’s kinda turned into a thousand dollar paper weight :>)

Any help will be greatly appreciated,

What do you mean by ‘chatters’? It sounds like it might not be configured correctly. You have your bed size correct and your homing switches are working? And the steppers are properly configured as well?

Hi Randy,

Please post pictures of your machine, board, and wiring so I can take a look.

That ‘chatter’ you mention sounds like the head banging into the side while looking for the limit switch during homing. If both the stock board and the C3D are doing it, there’s a good chance that a limit switch isn’t working, possibly from a loose or damaged wire.

Hi Blake,
Not sure what’s making the chatter(maybe the belt) but it occurs when the Y axis is reached and the X axis is still traveling. It makes me cringe when I hear it.
When I plug the SD card in to read the txt file that configures the Cohesion3D board, the computer wants me to format the disk.
I did configure the bed size through the software to 200 x 300.
I have no idea how to configure the steppers.
Research goes on…

Hi Ray,
I’m not sure if the photos work, but here goes.


I’m tending towards a faulty end stop switch too.
Could this also stop the software from working?
Is there a way of taking them out of the system??
I guess surgery is in order.


Hi Ray,
After looking at the photos I uploaded, I notice that I had the Y cable plugged into the X socket.
Things are working now, but I still have the chatter when it Homes.
I’m also getting a “out of boundary” alert, no mater where I place the small image on the drawing board.

Back to YouTube !!
Feel so dumb !!

Thanks for the help,

Did you check if there is an user origin set in the firmware?
I run into the same trap and after disabling the user origin everything is fine.
What firmware are you running? Smoothieware or GrbL? (You can see this when you connect to lightburn: GrBL shows something like this when connecting:

Grbl 1.1e [’$’ for help]

If it is GrBL, you could post the text what you get when you enter $$ to the console window of lightburn and we can check the setup together.
Also try the solution which was given when I asked for help: SOLVED - Origin set, but can't delete it

Hi Roy,
I think I’m using Smoothieware.
I will also look into the origin settings tomorrow.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.