No correct dimensions of a square when engraving

It’s looking better it seems but not quite right.

Can you type ‘$$’ (without quotation marks) into console and respond with results? Might be something in your configuration.

This is my configuration:

Did another test. But this looks not that great.

I don’t understand why some parts are good and some parts aren’t.
i expected that everything would be good or not good.

Did you make changes to these?

No i did not change the one your are referring to. I only changed $120 and $121.
$120 and $121 were set to 1000.000 so i change them to 200.000.

I think the middle sections are those areas where it’s moving the fastest after the laser head has fully accelerated.

This makes me think you still have some mechanical looseness somewhere, likely on the X-axis. Check also if there’s a lot of forward and back motion if you try to force the laser head against the gantry and also the other direction. The wheels should hold the laser module fairly firmly where there’s not so much movement.

I did make the x-axis belt more tighten. Now in the middle it is better. But at the end not so great.
also i did tighten the Y-axis, but the result is the same. And as you can see the lines are not straight but wobbly towards the end. The speed that i use is 1000 mm/m and power of 50%.

i tried the same settings but with some lines. No i am getting no more straight lines. Belts to tight?!
I am lost :neutral_face:

Try burning at a much slower speed (200mm/m) and see if the artifacts go away. If they do, then still likely mechanical.

Also, you tightened the belts but did you also check for wobble between the wheel and tracks?

One other thing I thought of that I don’t think we’ve discussed here. Can you examine the pulley on the stepper motors and specifically the grub screw to make sure there’s no slipping?

That might explain the wobbling at the edges.

i set the speed to 200mm/m and the lines are now straight :grinning:

Well they don’t look straight, but that’s because i took a picture of the engraved paper.

That’s great. So at least you can get straight lines at those speeds. This almost guarantees that any remaining issues are mechanical and due to slipping or looseness somewhere.

1000 mm/min as you previously attempted should be achievable. You can either start burning with what the machine is capable of now and tune it as you get comfortable with how it works or just keep tuning. The reality is, at least for me, that you never really stop tuning when it comes to settings at least (speed, power). I’ve had to fix grounding issues, add a solution for air assist, diagnose and replace a failing laser module… I think for some this is part of the fun and frustration of the hobby.

Yes I am also very happy with that that I now have straight lines again. I was already getting head worries :laughing:

But what i still not do understand is, when i draw boxes next to each other they are in line as you can see in the picture. Except the first box.
afbeelding 03

But when i draw boxes on top on other boxes they are not in line. Also the size of the boxes are also not correct. Is it certain that it has to do with adjustment of, for example, x-axis or y-axis?
The lines beneath are straight so you would think everything should be good.
afbeelding 01

You mentioned in an earlier post that the laser module should be hold firmly with no movement. There where screws on the underside that i could adjust. Now the laser is more firmly than before.

That is very odd and not quite sure what could be causing that. It’s almost like the motor is missing steps.

Some things to try in order to better understand the situation:

  1. Can you very carefully measure all the dimensions for every square and see if there’s a pattern to the deviation? It’s hard to say if only some of them are incorrect or they’re all incorrect.
  2. Can you use a square to demonstrate that the angles are indeed square? Just want to rule out that possibility
  3. Did you confirm that there is no slipping of the pulleys on the stepper motors? Particularly the X-axis. It almost apperas like it’s under stepping or overstepping at times on the x-axis. This could caused by a loose pulley.

Unfortunately, I can’t measure it until next week. but as soon as I know more I will let you know quickly

Today i had the time to measure the dimensions for every square. The angles of the boxes are square.
I also looked and tighten the pulleys but there was no slipping. I did some more test and it is not getting better.

When i engrave all the boxes like you see above in the picture. I don’t see any pattern. The first is “ok” the second is getting worst and the third, well that one looks awful. All this was done in one go/file. So these are not three separate files.

It is a little bit hard to see but, from 7 to 19 they line up perfectly but the lines in between are not.
for example from 7 to 8 it is perfect, from 8 to 9 it is a little bit of(box smaller). 9 to 10 and 10 to 11 are also of(box smaller)

Also when engrave the group of boxes side by side they are different then when i leave a little gap between the group of boxes.

Wow. Those results look worse than the other day.
I’m going to assume for right now that you have not overtightened the belts. They should not be stretched.

Are you absolutely certain the pulleys are not slipping on the stepper motor shafts? I’m trying to think of anything that would cause this type of behavior.

Try one thing.


Save your configuration and try setting these very low, like 10. This should dramatically reduce acceleration and stress your machine less. If things improve at that setting that would make me think there’s still some sort of slop in your mechanics.

I’m not really sure where else to take this. Hopefully someone else can provide some critical insight.

I tried the settings and i went very low as you can see in the picture. But still no improvement :expressionless:

The second of the group of 6 boxes are not even aligned with the first group of 6 boxes. Well the first box is aligned with the second group. :roll_eyes:

I will try to contact the seller again. I hope they can still do something for me.
In any case thanks for the effort taken to help me. :grinning:

That’s curious that it made no difference. So whatever is causing it is unaffected by speed or acceleration.

Were you able to check if pulleys were loose on the stepper? But even then I wouldn’t expect you to have a problem on both axes.

Perhaps try one other test. Try burning a circle. I’m curious if the start and end will touch.

I’ll be curious what the seller comes back with. You may want to consider getting a replacement unit if they can’t resolve it quickly.

The pulley were not loose on the stepper motor i doubble checked:).
I am now getting better results with the boxes. It’s not perfect yet but i am getting there…i hope. On the X-axis i loosend the screws a little bit so there is a little slack. Unfortunately i do not have any pictures at this moment of the better aligned boxes. Dimensions are still slight off but with these setting i can be satisfied. Maybe with further adjusting i hope the get the perfect aligned and same height and width boxes.
About the circles they are also better. Previously the circles where not round but more an egg shape.

1 Like