No graphics in the machine panel

I am aware TopWisdom is still Beta. Just a quick question:

The panel at my machine just shows a vertical line instead the expected graphics of the current file.
There was a similar question in November.
Is this still something still worked on and to be expected to work when officially released for TW?
Or is something wrong with my machine?

I believe this is fixed now - Do you have the trial downloaded from our site?

I ask because I’ve never been able to reproduce this issue myself, but I have locally tested on both 403CB and 410C and neither show the vertical line on the display.

Hi Oz
I used the link you send me earlier this week for a direct download…

Can you tell me the model number of your controller?

It’s a TL-410C Mainboard

Additional info taken from the machine panel:

That link gave me a 404:

Just a minute, I try another way…

Ahh, the first image is just how long you’ve used the laser. The second might be useful - Mine says:

Ver: V.L017.104
Equipment no: 01812336
Version type: 0

I guess most of the 2 minutes Laser time was factory testing :wink:
So it seems I have a slightly newer version. IMHO its unlikely that´s the culprit. do you have info from the other users having the same issue?

I don’t, but I’ll start asking.

Lets hope there is an explanation and its fixable. I rearranged my office to have the laser close by. I will continue getting my feet wet at this time the graphic in the machine should be too much of an issue. Later on when running its a different issue…
Thanks for looking into it.

Interesting detail:

If my cutting file has just one object the machine shows one vertical line in the display. If there are more objects in the file the display shows smaller vertical lines according to the number of objects.

Conclusion : The display “autozooms” but seems not getting the X axes information to built the graphic; X seems to be always that one location horizontally where the objects are located.

Perhaps this information helps a little to pinpoint the problem…

Screenshot with 4 Objects

Display with 2 objects

Display with 6 objects

Sorry, don´t have a display shot with 4 objects but I tried it several times with different numbers of objects to confirm my statement above.

I was thinking about this vertical line issue and thought I would look at the firmware. Mine is .105 as per above and I get the vertical line. I have never had any kind of split line. I notice from the Topwisdom site that ver .108 is available to download. I am reluctant to install it as I am getting by on the current level and I don’t want to break anything.
Will you be testing against .108 going forward or will you remain with .104?

I’ve been able to reproduce this - I downloaded the new firmware into one of the controllers I have, and still got a proper display. Then I changed my device origin to the right instead of the left, and now I get vertical lines. I should be able to figure out what’s happening from here.

This is fixed and will be in the next release.

1 Like

Great news! Thanks for the hard work.

That is great news. What is the next area we should be thinking about, is there any testing the community can help with?