No laser fire button

I’ve been using xtool D1 laser for 2 years and running older version of Lightburn. No problems. I broke my laptop recently and after getting a new one and now running latest 1.6.01 version of lightburn, I now have no Laser Fire button. I have checked device setting and the option to turn the button on is not there, as it was in the older version. I’ve got jobs piling up…please help! :slight_smile:

I found it here in version 1.6.01.
Hope this helps. :smiley:

Thanks for the reply. As you can see, I don’t have that option for some strange reason.

I see your settings are for X Tool and mine are for GRBL, so I’m not sure what’s going on.
Might need to get help from other’s like @gilaraujo or @parsec .
Sorry I couldn’t be more help.

Did you setup your XTool with a XTool_D1.lbdev file?

1 Like

No, I didn’t. And I have no idea what you are talking about if I’m being honest! I set it up exactly the same way as I did on my previous laptop - using the ‘Add device’ facility. However, this time Lightburn could not detect it, even though it was powered up and connected through the com port. I used the facility to add a device manually and selected Xtool from the list. I know It is connected as the device auto-homes when I select the com port.
So I am baffled!

Thank you anyway. Appreciate you taking your time to try and help me.

Enable Laser Fire Button in the device Settings window?

In Lightburn laser window

  • 1, Click Devices button
  • 2.Click import
  • 3.Browse to where you have the file, select Xtool_D1.lbdev and click Open.

    xTool_D1lbdev.txt (3.2 KB)
    This file has scanning offsets already defined by XTool.
1 Like

While you can use the procedure presented by @parsec, you also have the option to use the Device Wizard to add support for your xTool device. This is a relatively new behavior, which was not available when you first added your device originally. :slight_smile:

Thanks @parsec that worked perfectly. I now have all the controls I used to have with a quick and easy fix.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.