No longer Dead in the water - but please note: Received error:9 G-code locked out during alarm or jog state

I’m getting this message when any GRBL code is being sent to the Shapeoko. I have just updated the software to current version (23).

At this point, I can’t burn anything and I’m in the middle of a job that’s time sensitive! Please help!

Starting stream
$10=0
$32=1
G10 L2 P1 X-845 Y-850
error:9
G-code locked out during alarm or jog state.
On or near line 2:
Stream completed in 0:00

I have not touched anything other than upgrading the software
I did not change my process from any other time…I normally do not home the machine and normally use “Start from Position” when running jobs
The machine starts up and initializes properly as a CNC using CarbideMotion

I looked at the other posts regarding error 9 - but they did not help me.

Help!

An update:

I backleveled to .20 and solved the issue. .21 failed as well. During startup, I see an unlock command in the console that I don’t recall seeing in the start up of 21, 22, or 23.

Anyway - I’m no longer dead in the water…but would still like to run the most recent versions.

OK: Discovered that the startup script for .20 has a command: $X which does an unlock.

It does not appear in the startup for .21 and recent.

Typing it in manually in the console, did the unlock - and then the “Use Laser macro” worked fine and everything else worked properly as well.

How do I edit the startup script? Is there any harm in adding the $X to my startup routine?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.