No response when I click Move[GRBL]

I use light burn to connect to the grbl control board. When I click move, the console outputs starting stream, and it is always busy. At this time, the control board did not receive any instructions. What might be the reason?

Can I ask why you are using version 0.9.18? Your laser is showing the machine position as -559x, -1500y, so it is not properly homed, which could be an issue, but it’s going to be hard for us to debug with your version being so far behind.


Very happy to receive your reply! I installed the software version 1.2.01. I turned off the automatic return to the original point in the settings, but the same situation will still occur.

If you need to update information to troubleshoot the problem, please let me know.Thank you again for your reply!

Can you tell me which laser you are using? (Your profile says AtomStack, but I just wanted to confirm that)

Try this:

  • Connect LightBurn to your laser
  • Go to the Help menu in LightBurn and turn on “Enable Debug Logging” (near the bottom of the menu)
  • Now try to jog the laser with the move button

If it fails, quit LightBurn, and go to your ‘Documents’ folder. You should see a file called LightBurnLog.txt - attach that file here so I can have a look. It will just contain information about the commands sent back and forth - no personal data.

Hello, I once bought the laser engraving machine made by AtomStack, but now I’m trying to make my own laser engraving machine. I made the control board myself and transplanted grbl to the control board.

Thank you very much for your advice! I checked the output information again and found that the buffer size of the control board output was zero, which made it impossible to move. I think I have found a solution, and I will continue to test. Thank you again for your reply! Wish you a happy life!

1 Like

That would certainly do it. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.