No Ruida, and no LAN

Lightburn vers. 0.9.09, my license doesn’t permit me to upgrade…
Just changed my laser from a diode laser connected via USB, to a CO2 laser with Ruida controller.
I can’t find the option to choose Ruida, and can’t find any option to connect via LAN ?
I can choose GRBL, and 5 other lasers, but no Ruida.

Regards, Kim

If you don’t see ‘Ruida’ listed, this indicates you do not have a DSP license of LightBurn. The DSP version is required to support the Ruida family of controllers. I just looked for you using your profile email address and confirmed you have the GCode version.

You can upgrade to the DSP version here:

Yes, found out, that that’s my problem.
Have just upgraded my license, so waiting for the order to complete.

Regards, Kim

I have manually processed your order so you should now be able to support your new Ruida. I also see that this key has expired and you are running version 9.09 which is now quite old. We just released, seconds ago, 0.09.15 and provide information about what we have been up to here:

Most recent release announcement:

You can continue to use the 9.09 version with your new Ruida but you can also purchase our Renewal providing another 365 days of updates to be added to your expriy date. This would get you current and allow access to our next releases dropped during this window.

Thanks, Rick.
How do I get the Ruida controller to show up on the list to choose devices ?
It still doesn’t show up…
Can I upgrade to version 0.9.11 with my current key ?


It’s not the version number - you might have to deactivate / re-activate to make it happen right away, or just go into Help > License and Trial, and wait a moment for it to update the license status, then restart the app and try it again. It normally checks in with the license server once a day, so you need to do something to make that happen “now”.

Problem solved.
Upgraded to 0.9.11
That helped

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.