No usb option when selecting device - M1 Mac

I am only given bluetooth options when I’m trying to select my devise, which I setup manually because it won’t auto detect. What do I need to do to get LightBurn to see my USB bus as a selectable option?

M1 MacBook Pro 14" with MacOS 13.5.
Creality CR10 Falcon - Updated to latest firmware
LightBurn 1.4.01

Just curious, have the appropriate USB drivers been installed? Not a Mac person here, but it’s the first thing I’d check if you haven’t already. In windows it will make a chiming sound when a USB device is plugged in, does your Mac respond at all when you plug it in? You might want to disable rotary until you get this figured out. You don’t any extra weirdness at the moment. Just my two cents worth.

Based on my reading I have seen that the CH34x drivers are needed. Some sources say I need to install them, others say they are preloaded by Apple with current OS versions. I have tried both ways.

The Mac doesn’t respond when I plug in the CR10. It doesn’t show up as a USB device in the system report. (similar to the device manager on windows).

I have tried all 3 USB-C ports, three known good cables (retested cable and ports with other devices). CR10 loads and operates just fine on my friends windows computer.

The issue persists with both the rotary on and off. I have been using the engraver with the TF card while I for this out (no I haven’t had both the usb and TF card plugged in at the same time, and I power cycle the CR10 every time I plug or unplug anything).

I have a separate ticket open with Creality about the engraver.

My main concern is the lack of a USB bus option on Lightburn.

I don’t use a Mac, but I run Linux, a cousin …

I use lsusb to find what’s hanging on the usb ports… I also look in the dmesg for system messages that could tell me if the device is there or not.

If your OS can’t see it, then Lightburn can’t connect to the device.

The BJJCZ USBLMCV4 is my fiber on the usb port.

jack@Kilo:~/mnt/dev-test/cnc/laser/fiber$ lsusb
Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 056a:0011 Wacom Co., Ltd ET-0405A [Graphire2 (4x5)]
Bus 003 Device 008: ID 9588:9899 BJJCZ USBLMCV4
Bus 003 Device 003: ID 25a7:fa67 CX 2.4G Receiver
Bus 003 Device 002: ID 062a:4102 MosArt Semiconductor Corp. 2.4G Wireless Mouse
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

This is the tail (last lines) in the dmesg output…

jack@Kilo:~/mnt/dev-test/cnc/laser/fiber$ sudo dmesg | tail
[sudo] password for jack: 
[124536.424794] audit: type=1400 audit(1692255610.252:40): apparmor="DENIED" operation="capable" profile="/usr/sbin/cups-browsed" pid=114319 comm="cups-browsed" capability=23  capname="sys_nice"
[162628.669558] TaskCon~ller #3[90018]: segfault at 7f344fc4ff30 ip 00007f3453e57b41 sp 00007f3441785998 error 7 in[7f3453cee000+178000]
[162628.669573] Code: 01 00 00 48 83 fa 40 77 77 c5 fe 7f 44 17 e0 c5 fe 7f 07 c5 f8 77 c3 66 90 f3 0f 1e fa c5 f8 77 48 89 d1 40 0f b6 c6 48 89 fa <f3> aa 48 89 d0 c3 66 0f 1f 84 00 00 00 00 00 f3 0f 1e fa 48 39 d1
[163886.347261] usb 3-7: new high-speed USB device number 8 using xhci_hcd
[163891.859067] usb 3-7: device descriptor read/64, error -110
[163892.119716] usb 3-7: New USB device found, idVendor=9588, idProduct=9899, bcdDevice= 0.05
[163892.119728] usb 3-7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[163892.119733] usb 3-7: Product: USBLMCV4
[163892.119737] usb 3-7: Manufacturer: BJJCZ
[163892.119740] usb 3-7: SerialNumber: 20200507

If you have a problem with it not recognizing it, it may state it was disconnected in the dmesg output… I don’t know if the Mac uses the same system file or not…

You might have to install lsusb


I just got my m1 mac air working yesterday. You need a driver. I used this:

Try installing that. This should then show you the usb option in that list which will allow you to connect to the laser. Hope this helps.

1 Like

Thanks for the info. I tried that one. No change. the operating system still doesn’t recognize the device as being connected. No usb option in light burn.

If I have to go through all that, I’m just going to return the engraver and buy something user friendly.

Creality claims it’s Mac compatible, but I have my doubts.

Did you check the terminal instructions as it states? The M1 has many issues like this. I do a lot of programming, hardware, etc and I always run into issues with the new M1 chip. It mainly because it’s new so there isn’t usually alot of support/data. It really is just making sure you have the right driver. I don’t think getting a different engraver will make it easier for you using an M1. I have a comgrow z1 and went through the same thing but did get it resolved. I suppose worse case scenario, you could get the Z1 since I can at least say I have it working. As a last resort, you can try this one:
P.S. Don’t forget to reboot the computer after installing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.