Nodes will not snap together

I am new to Lightburn and my laser. I am trying to snap nodes together, but they won’t connect. They will act like they’re snapped, but it won’t close the line. When I go to preview, I get a message telling me they are not closed. I don’t know what to do to get them to close. I’ve also noticed that the nodes are different. Some are a green square, some red square, and some green or red circle. What does this mean?

In the first image, I’ve circled the line I want to remove:

In this image, I’ve circled where I’m trying to snap the nodes together, but they aren’t snapping:

This image is showing that the nodes look different compared to the image above:

This is the error message I am getting when I go to preview:

Squares indicate a corner node, circles indicate a smooth node. All nodes are green unless selected at which time they become red.

I’ve noticed issues with getting certain nodes to snap together. In general it works but it seems there are certain conditions where this does not work but I haven’t seen a specific pattern as yet.

Can you upload your .lbrn file for review?


2010 Gun.lbrn2 (106.5 KB)

I think what you’re seeing is the same as those times I’ve had the same issue.

The only way I’ve found to be able to fix this is to do the following:

  1. Select the shape that won’t close
  2. Arrange->Break Apart. This will result in all the component segments of the shape now being separate objects.
  3. Select all the disparate objects that make up the original shape
  4. Edit->Auto-join selected shapes. This should rejoin all the parts hopefully into a single closed shape.

I’m hoping I’m wrong about this and that there’s a cleaner way to handle this. I welcome @LightBurn, @Rick, or anyone else from the team to review this as it’s been an annoyance for me that I haven’t yet explored in depth.

1 Like

One way to do it is to select the offending object, then [Edit]… Close selected paths with tolerance. Don’t try this method if you are feeling a bit irritated :grinning:

Did you attempt that with this particular file? That didn’t work from what I saw. This isn’t a normal scenario where the nodes are behaving as would be expected. I’d put this in bug-like territory but reserving that in case I’m just missing something.

I’ve noticed this too but like you I haven’t come to any conclusions as yet.

This worked!! Thank you so much! I feel like this isn’t normal, though, and is something that needs to be looked into and fixed. It has been a huge issue for me since I’ve started using Lightburn. I just thought I didn’t know what I was doing and missing something. Thank you so much for your quick response and help!

Glad that worked and agree that it’s an odd situation. I’m not yet certain it’s definitely a bug but leaning that way. Would be happy to learn it’s just missing knowledge.

How were these shapes built originally, what was used to draw this? How did you bring these shapes into LightBurn? What file format is used for these shapes?

It’s a .jpg that I imported into Lightburn and did a trace image.

For the record I know for certain that I’ve seen this with imported SVG files created in Inkscape. I’m not certain if I’ve seen this with LightBurn native shapes.

The times I’ve seen this I’m pretty sure have all been scenarios where I’m starting from a closed shape and using node edit tool to break nodes apart. It’s in the reconnecting that the issue manifests.

Is that all you did, or did you do a bunch of editing first? I’m trying to figure out if the trace tool produced the bad shape, or a sequence of node editing did.

1 Like

I did do editing first. However, I clicked preview after snapping each node together to make sure they were actually closed. They all closed until I got to the point I posted about.

Ok, then it’s likely something in the editing that messed it up. This is a known issue and we’re working toward fixing it, but it’s complicated to do so because of how LightBurn stores the shape definitions internally. (explaining why it fails gets really technical very quickly)


I’ve had the same problem with jpeg photos that I imported and traced. They are recipes and I’m attempted to remove the line from the recipe cards and just leave the writing. I found the path with tolerance worked for me.

I am so lucky that I also have Vectric VCarve. When I have these problem, I export the file as svg, import it in VCarve and run the node editing there. Takes only a few seconds and I export it back as a svg file again, and the it is fixed. I have this issue four or five times a week. I wish Lightburn had the same node editing features as Vectric. But we will see what Lightburn comes up with. For me, this is the onliest flaw with Lightburn.

As a work-around, if you select the shapes and press Alt+B (break apart), then select again and Alt-J (auto join) this almost always fixes it. I’m going to look into this soon and see if I can make it behave better.

1 Like

Looking at your file, the problem is in a different spot, here:

If you zoom in, there’s a little “tail” off one of the nodes. Delete that, and the warning goes away.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.