Not communicating with eleksmaker


(Pietro Espo) #1

I’ve been using lightburn with my eleksmaker 2.5 for the past 7 months and yesterday morning its not connecting at all. I have tried the following… changed the usb cable 3 times, updated the lightburn software to 9.04 , restarted computer, updated computer and tried the “find my laser” … at the end of the day I just need to find out if there is a way to check the controller to see if its the problem. I have explored this forum and couldn’t find anything that helped. If there is a customer support to call that would be great, I have dyslexia and I have to translate alot to sound. Thank you for any help I have a project to get done and this just sucks.


(Blake Bartlett) #2

So it wasn’t working on a previous version of LB? Does the eleksmaker allow for connecting via ethernet? Can you copy a file to a flash drive and run it from that?

Did you do anything that might have caused the connection issue? Anything random that happened before it stopped connecting?


(Pietro Espo) #3

Yes it was working fine on the old version of LB. yesterday I plugged in the eleks and “Waiting for connection…” I don’t think the eleks has the ability to connect with a ethernet or flash drive. I cant think of anything that would make this stop connecting, I only use this a few times a month if that and the last time was in May and it worked fine. how would I test the hardware with out buying other software?


(Oz) #4

It stopped working before you updated, correct? I would check to see if Windows Update messed up the driver. When you plug in the Eleksmaker do you hear the ‘Bing!’ that windows makes to tell you a new USB device is plugged in?


(Pietro Espo) #5

it did stop working before the LB update. when I plug the eleksmaker it doesn’t “Bing” but the elekmaker does know its connected because the light on the controller comes on.


(Oz) #6

That means that Windows isn’t recognizing the controller, so it’s most likely a driver issue. Look in your windows device list to see if anything isn’t recognized, and see if you can download a driver for the board to re-install. I’ve seen Windows update cause driver problems before.


(system) closed #7

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.