Not cutting inside first

This file will not cut inside first, Have set for inside first, everything is ungrouped, checked for open shapes and none found. Tried to auto join all but there didn’t seem to be anything not joined.heart inside heart.lbrn (66.6 KB)

Ungroup the outermost heart shape. It is grouped with the inner shape and my guess is you also have ‘Order by Group’ ON (green) in your optimizations. Then try in ‘Preview’.


Can you show a screenshot of your Cut Optimization Settings?

Is “Reduce travel moves” turned on? Sometimes that seems to wreck “Cut inner shapes first”.
Don’t know why. I’ll bet Oz does.

I will give it a try in the morning. Thanks guys for quick reply.

I did a select all ungroup couple of times, I am surprised to see those two grouped yet.

I am sure reduce travel is on.

Will post tomorrow results

The reduced travel moves was causing the problem.

Thanks everyone

This is not what I was finding @wentzele and @Hank. The file posted has two paths defined as a group and are being cut as you want, cutting the inner first and then the outer shape. This is what is causing your file to cut in the undesired order. I will explain why.

These two shapes are cut during the first part of the job due to having ‘Order by Group’ ON (green) in the ‘Optimization Settings’ found in the lower-right of the ‘Laser’ window. This setting tells LightBurn to run paths that are part of a group together, overriding any other planning. Items that are not grouped are treated as though they were in their own group together. With the ‘Cut inner shapes first’ also applied, you see the smaller shape of the group being cut first as this setting is applied to each ‘set’ of optimizations.

If I ‘Ungroup’ these and select ‘Preview’ again, without further adjustment to your source file, the job cuts as you want.

I also noticed you have this layer set to 2 passes.

Interesting. Thanks Oz for the explanation.

If I take wentzele’s drawing and run it as is with those items still grouped, and I run it with NO “order by… settings” (all removed), and with “cut inner shapes first” checked it runs fine. If I also check “reduce travel moves” then it no longer cuts inner shapes first.

I guess I kind of expected “reduce travel moves” to do the best it can while still respecting “cut inner shapes first”, but it does not.
I’ve run across this before and have had to turn off “reduce travel moves” to get “cut inner shapes first” to work right. Is that expected behavior?

Thank you for the further evaluation, and the “Thanks Oz” compliment, but it is just me, Rick. :wink:

I am sure his description of the priority and ordering of these optimizations will be much clearer. While we are here, this is a good review of the cut planner, how it works and how to optimize the settings for different desired results.

Ooops, sorry Rick! That’s what happens when I’m using one of my brain cells to think and the other one to type…

I’ve watched that video a couple of times in the past but it’s probably time to review it again to see if I learn anything new.

1 Like

The top three items in the cut planner (Order by Layer, by Group, or by Priority) take precedence over the stuff below, for the most part. If you have ‘Order by Group’ on, it assumes you’re doing something like running a bunch of keychains, where each one is a group and needs to be treated as a unit before moving on to the next one. Similarly, ‘Order by Layer’ can also override the inside / outside path ordering.

Having the order overridden by one of these ‘master options’ or not having your shapes closed are the two reasons I’ve seen the inner / outer sort fail. It’s very predictable otherwise.

I I discovered that.


Thanks Oz, did not realize the order by overroad the lower selections. Need to do more playing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.