Not enough Buffer Space

Hi I have checked previous queries with regards to this topic but doesn’t fix my problem> I have updated this computer to LightBurn 1.5.06, built Wed 2024-03-20 @ 17:00
Created by LightBurn Software, LLC
But since doing so my CO2 laser with Ruida controller keeps giving me NOT ENOUGH MEMORY BUFFER when I try to engrave. I have cleared my machines job memory and this job is the first since I have upgraded to 1.5.06. The Origin is about 10mm off the x and y limit switches. my engrave speed is set to 300mm/sec and 20% power which I have previously been using. The engrave I have previously done in 1.5.01 I think it was previously. Can any one advise what I might need to change in settings to avoid this problem
Kims 70th.lbrn2

Remove some of the other jobs stored on the Ruida… You can delete them all via Lightburn, if not needed.


I don’t have any jobs loaded to the laser as noted in my earlier post as I usually delete after burning. Just can’t use Lightburn as it is at the moment. I can create an RD file and burn from that. I have tried 2 computers, 3 USB data cables and still get the message in Lightburn saying the laser is not available and the laser when makes contact I get the not enough memory buffer. Ruida is selected for the device settings but only indicates (Auto) usb connection in Lightburn port selection. I also can’t access the controller info. It seems as though Lightburn just doesn’t connect.
It has only done this since I did the Upgrade 1.5.06 on my CO2 computer I don’t have a problem on my Falcon 2 Diode only the Ruida laser

USB with these are a real pain… I’d suggest, if possible to use an Ethernet connection to the Ruida. Much more dependable.

I can’t really tell if it’s not connecting or if the Ruida is having issues.

Is this on the Ruida console?

When you mention an error, let us know who is complaining, Lightburn, the os or the Ruida.

If you select file on the Ruida console, does it show any files?


No files on the controller and yes the controller reports buffer error when I try to send the Lightburn file. No problem with the OS only Lightburn not working. I have tried ethernet but still can’t connect through Lightburn even though the IP’s are configured correctly with Ruida and computer

It looks like the image you’re engraving was processed (dithered) outside of LightBurn. Try enabling “Pass-Through” mode instead of using Stucki, which is double-processing the image.

1 Like

I have done two of these jobs before without a problem in previous version 1.5.01 of Lightburn without having to do pass through and both came out correctly. Do I need to downgrade to 1.5.01 and where would I get the file. Seems a shame as there seems to be benefits in processing speed in 1.5.06 that I have noticed on my diode laser

I strongly recommend trying Pass-Through mode before reverting your version of LightBurn — you may have had success in a previous version, but re-processing an already processed image has never been advisable.

All previous releases of LightBurn are available here:

Apparently the laser was shutting down my computer usb controller which I have now fixed and have changed the image to pass through and was able to send to laser. All happened at the same time so not sure which fix corrected but thanks again for your help

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.