Not enough extended memory error when sending 3D Graphic file to Ruida 644 laser engraver

I have been previewing LightBurn on my 700mmx500mm 60 Watt Ruida 644 Laser engraver. I had saved some 3D JPG files and was messing with them in Adobe Photoshop, and when I tried to send them to the Laser engraver, either by USB cable or by Ethernet, the controller gives me a “Not Enough Extended Memory” error, and I have to hit ESC to continue, and it doesn’t start the job. I have tried loading by Disk, and that didn’t work either. I am stumped! I have another graphic file that I just made larger and increased resolution to 300 in Preview, and it works fine. What is causing this error in extended memory? I have tried resizing the file smaller, and it still gives this extended memory error in the Ruida controller.
Actually it says not enough extended space, I just rechecked.

If you have a lot of files you have sent to the controller, it does not over write them as new ones come in, you have to go in and delete them. It’s one of the reasons the only files I send to the controller instead of starting them from the software are my test and calibration files. Everything else is sent from the software. When you go to the controller and pull up your files, how many do you see listed?

I have no files in memory, I checked first and deleted the one file I had sent, and I even formatted the memory in the machine after that, and still get the ‘not enough extend space’ error… it really didn’t say ‘memory’, that was my assumption from the cryptic Chinese interpolation of the English language.

And of course the message would be on the controller screen instead of the computer where you could cut and paste it into Google Translate.

What is the memory specs of your controller? Only the partial model number posted, just 644?

It’s a Ruida 644XG according to LightBurn Devices.

The chart says you have 128M of on board memory. If it’s the only file, you should be good unless it’s very intricate.

Can you show a picture of the error? Is it “not enough extend space”? That would just mean you placed it too close to the edge of the machine. Ruida’s translations aren’t very good, so if you’re using it in another language it might be translated to “memory” not actually mean “distance”.

1 Like

Yes, it is in English, not Chinese, and that is exactly what it says. ‘not enough extend space’, as soon as I send the file to the laser, it beeps and gives the error, and it never actually stores anything into the laser controller memory. It seems to be only the hires files that are listed as 3D rendering. here is one of the files that give the error, changed it to 300dpi. I put the graphic in the upper left corner of the workspace, just like the one that actually works, and it gives the error.

“Not enough extend space” means that the laser doesn’t have enough room for the overshoot that happens when scanning. If you put the graphic right in the corner, that’s the issue - move it away from the side a bit, so the laser head has room to move past the engraving area to slow down and switch direction.

1 Like

Yes, that was the problem, the first file I used wan’t giving me this message, so I forgot that I took the home off of where I had it before, and now it works fine! Thanks for the help, all of you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.