“Not enough extended space” problem

I am having issues lately with completing larger projects. So when engraving most of my images I always do a few smaller test pieces to get power/speed/DPI and all that where I want it. Then once satisfied I do it on a larger scale. Well the last few projects my test pieces have come out just fine but when I switch it to a larger scale (usually 2 feet by 1 foot) the project will get about half way through and then randomly veer all the way off the project to the end of my bed and hit the stop and get the message “not enough extended space”
The project is is in the middle of the table, multiple feet away from each X axis rail so I know it’s not the issue of the acceleration and speed of the laser head. Also the test projects at a smaller size always come out just fine with no veering off.
Keep in mind this has been happening with more than just one image.

Any help is appreciated

Are you using “Send” or “Start” ?

My suspicion is that you’re using ‘Start’, and are running the jobs at fairly high speed, given the size. If you do that, you can overload the controller, which will make it drop incoming packets - it basically is too busy trying to run the job, and misses incoming data, the commands get jumbled, and things like this happen.

If you use ‘Send’ and then run it from the machine then it’s only doing one thing at a time. You can also use Shift + Send to have it auto-start after the send.

Honestly have never tried the send button. I do understand what you’re saying though because Everytime I’ve tried larger engraves I’ve noticed the bar sending information while it was trying to engrave. I’ll give this a shot thanks
How would I go about running the file from the machine after it’s sent?

Or you press the ‘File’ button, find the file in the list, and press Enter to open it. Then you can Frame or Start on the controller itself.