Not Enough Extended Space - Troubleshooting and bug report

I’m running a 1300x900 laser bed on a Ruida 6442S-B(EC) controller.
LightBurn version 0.9.11

I discovered this error while trying to make a Scanning Offset Adjustment test pattern for speeds 100-600mm/s. My initial test had 6 vertical aligned boxes, each with it’s own color and increasing speeds and power.

After getting the error I simplified this for the sake of testing since I pinpointed what settings are causing the error. I’m now working with six 5x5mm boxes vertically aligned and in the center of my 1300x900 bed. Over travel and ramping are not the issue. All of the layers in this test are set for 1mm intervals so roughly 25 lines per inch, but the results are the same regardless of the interval. I’m also using 300mm/s but get the same results with other speeds. As long as the boxes are all the of the same color/layer the error does not occur. Once a new layer is in the mix, like the alternating black and blue layers, it causes the error.

In each of the following tests I selected a column and then Start to run the test. Here are the results.
First test, I selected the Left Black column, it runs fine.
Second test, I selected the Middle Blue column, it runs fine.
Third test, I selected the Right Black and Blue column, it starts at the bottom, runs the blue box, moves up to the next blue box and runs a couple lines then gives the error, “Not Enough Extended Space”.
The error occurs whenever Optimize Cut Path is Turned Off, OR when it’s turned On and set with Order By Layer.
The error does not occur if Optimize Cut Path is Turned On, AND Order By Group OR Order By Priority are selected. Adding Order By Layer anywhere in the stack will cause the error to occur.

I hope this is enough troubleshooting and detail for you to re-produce the error on your end and find a resolution. I was unable to re-produce the error in RDWorks but it doesn’t have the nice optimization settings that LightBurn has.

Box Test No Error.lbrn (10.6 KB)

Box Test with Error.lbrn (10.6 KB)

Can you attach the file?

I’ve attached them in the original message now. The With error has Order by layer set and the No error has Order by group set in the Optimization Settings dialog.

This is bizarre - your file has a start & end delay on the blue layer, but it’s a fill, so it should be ignored. If I flip to Line mode and remove the delays, then flip back, it doesn’t give the error any more. I’ll fix the code so it doesn’t do that.

I got the same error message, but a slightly different scenario.

I set the speed to 1000 mm/s and got the error. I set the speed to 500 mm/s and got the error. I set the speed to 200 mm/s and it started working.

thats because the machine needs less space when going slower

Is there anything I can do, e.g. add more memory, to increase “extended space” so that it can handle faster speeds?

At the end of each engraved line, the head needs space to decelerate to a stop and then accelerate in the other direction to get up to engraving speed for the next line. If the controller thinks there isn’t enough distance at the beginning or end of the engraving, you get the extend space error.

You can:

  1. Move the object to be engraved away from the edges of the bed (center it)
  2. Engrave slower. It needs less space to accelerate to the lower speed.
  3. Increase the stepper motor acceleration. This needs to be done cautiously because excess acceleration can cause the motors to lose steps, which creates a new (worse) problem.
1 Like

The issue that some, including myself, are dealing with has nothing to do with actual “Extended Space”. My bed is over 4ft wide and I run into the “Extended Space” error when trying to do a one inch block in the center of the bed at any speed, if certain conditions are. In my case, certain combinations of multiple layers and optimization settings seem to trigger the extend space error. If you read my original post, my issues can be fixed by running one layer at a time or changing some of the Optimization settings. Fortunately Oz has said he’s fixed the code causing the issues, so the next release shouldn’t cause this particular issue anymore.

There are times when too wide of material (or too small of bed) causes the machine to run out of space or travel required to complete a job but this particular issue isn’t related. If you really are close to the edges of the machine and get the error then the suggestions others have offered will help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.