Not moving after update

Just updated lightburn last night and tried to use the laser today. The move panel in lightburn wont do anything, I am still able to burn files I just cant move the laser to set position or z hight. I have a 4.2w jtech on an x-carve.

Turn off continuous jogging - that’s quite probably the issue.

@adammhaile - Is it possible that $J jog moves aren’t supported on older versions of GRBL?

@LightBurn yes, continuous jogging and jogging in general via $J is only supported in grbl v1.1 (so 1.1a through 1.1h as of now).
I do not believe we currently actually do any checks in the GRBL profile to confirm that you have v1.1 we just assume that you chose the right profile.
Sadly, if @Camcam90 does have a pre-1.1 version then even non-continuous jogging won’t work because it also uses the $J. However, in that case the laser shouldn’t work because it’d be using the M4 command which is also a v1.1 thing as far as I know.

@Camcam90, if you go to the console if should show a grbl startup string with the version when you connect. Can you please send that to us?

Also worth asking - Are you doing the origin change macro, or do you normally just jog into the workspace and run from there? (IE - Do you have your origin set to front-left in LightBurn using the recommended macro?)

@adammhaile I am 1.1g, @LightBurn I have never been able to get the laser to home properly (router will home in easel but laser wont in LB) I worked with yall and jtech in the past to figure it out with no luck, so I use the start from current position option and jog the laser where I need it.

@Camcam90 ok, it’s probably because x-carve using a weird modified version of grbl. Given that it doesn’t home correctly I have lots of concerns. That should be pretty standard.

We’re going to push a fix soon that will bring back the older grbl homing method which should get you back on track. Sorry for the inconvenience.

@adammhaile no worries, just reverted to

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.