Not recognizing set origin?

Foxalien 4040xe, 80 w laser. Dell, windows 10. Laser was working fine. Yesterday i went to make a cut. It homed on startup, framed the work, then darted off to upper right corner on start. I have had this happen before, finally got it to work after deciding I had to use the set origin, not realizing that was the same as zeroing (Right?). I tried all the different start origins. I deleted old prefs. I did a practice burn using Candle and it worked so laser is functioning. Again, is this some tiny little thing I’m missing?

Not really following what you mean here by set origin being the same as zeroing. Can you elaborate?

Note that setting of user origin is really only valid when using “User origin” start from mode.

Can you provide the following:

  1. Full screenshot of LightBurn with your design loaded and ready to burn
  2. Run these commands in Console and return full output:

The first command will home the laser so be prepared for it.

Ok, I’m probably not sure either, i re-read the origin instructions over and over. It says absolute coordinate is easiest, i don’t see how, unless you’re engraving and cutting a design from a larger piece of material. My designs are all on pre-sized material, so i have to be able to place the start position precisely. I was using user origin, then either center or a corner. I got the “may be out of cut bounds” message, which i read was caused by not using the origin positions correctly. But it would cut where it was supposed to. When I started a couple of weeks ago, i had this same problem with the diagonal travel. It seemed to stop if i placed the laser where i wanted it to start from and use the Set Origin button. But that doesn’t have anythingvto do with it? I was able to use the laser and burn a design in LaserGRBL, so everything is working. But i like Lightburn, and have paid for a license so need to figure out why it quit working overnight. Thanks. You guys are great about responding. I’ll check those values tomorrow.

This means that LightBurn believes that you are going to run out your boundaries. So either the controller is telling LightBurn the wrong thing or there’s legitimately a problem.

This would be trivial in Absolute Coords if you were to have a mechanism by which you could place the material at the same location every time. Typically this is done with a jig if high precision is required. Else you could do this by hand placing on top of grid markers. Or you could simply move the design in workspace until it matched the bed location of your material.

But there are many workflows that all work perfectly well.

Then yes, you definitely would want to set origin using this approach. If you were getting error message it’s likely either because your machine is not homing properly, you’re moving the laser head by hand, or because the design is larger than the available clearance from set origin to laser boundary, or because the controller doesn’t understand the true size of the laser frame.

If you can send the output from the commands when you get a chance I or someone else can help you sort through that.

Can you confirm that the working size of your machine is 400x400 mm? I’m assuming this based on the name of your laser.

Sorry, i guess I don’t know how to get pics on here. I’ve tried upload. Tried copy and paste. Tried drag and drop. Got my phone screen all jacked up and had to fix that.

Machine homes on command. Moves on command. Fire button works. Frame or run just sends it diagonally lower left to upper right. I know you need the pics, please tell me how to do it. I dont know what markdown, or HTML format or any of that means. All i know is put it on the clipboard and paste. I don’t mind learning new stuff but I’m getting tired of being a full time mechanic just to drive the car. (Laughing sadly). I spend more time researching than doing.

Aye, that’s what the “learning curve” looks like from the bottom!

Nobody starts out knowing this stuff and, fer shure, the folks selling the lasers do not go out of their way to make it obvious these things are not consumer-grade pushbutton appliances.

Although it’s not much consolation right now, you’re on your way to becoming an expert … :grin:

Lol, yes, I know. More frustrating because it was working fine, then overnight decided not to.

What happens when you did these things? Upload should bring up a file dialog where you can choose the file to upload.

While you’re sorting out how to upload the screenshot can you run the other commands and return the full text from Console? It’s preferable for that to not be a screenshot actually, just text.


$1 [:1.1h.20190825:]
Target buffer size found


[G54:400.000, 400.000, 400.000]
G56 through G92, 0.000, 0.000, 0.000
PRB 0.000, 0.000, 0.000

This was on the console as it traveled left to right diagonally.

This is likely what’s causing the issues that you’re seeing but can’t quite tell.

One of the listed commands was missing in your output. Can you run this in Console and return output? The first will home and the second will return status.


<Idle|MPos:397.000, -397.000, -3.000|FS:0,0|WCO:400.000,400.000, 0.000>
There has been some lightning. Is it possible there is electrical damage?
LaserGRBL tries to run a file but i don’t know if I’m not placing it right, it starts at the bottom of y axis even though I specified center horizontal and vertical, runs a few lines then gives an alarm. I can’t even get a file to open in Candle.

If there is I’m not yet convinced that’s the problem.

This is the likely cause of your issues.

Do you regularly use this machine for mixed CNC and laser operation? If so, that might be posing some of these challenges.

Also, want to make sure I don’t offer something that will put you out when you use the machine for CNC operation.


  1. To what corner does your machine home?
  2. Can you provide a full screenshot of LightBurn with a design loaded and “ready to burn”
  3. Provide a screenshot of Edit->Device Settings

Well, at least the files appear to have uploaded. This morning, it looked like runic hyroglyphics. I used the cnc for the first 6 months, then switched to the laser the first of June. I fought with it for three weeks before discovering the "Enable laser= true/false button. Has worked fine for three weeks, then day before yesterday, it went wonky. The laser will be my primary tool.

Homes to lower left. And thanks for your amazing help, I am so grateful.

I wouldn’t have expected that based on the current values.

Try this. Run these commands in Console:

G10 L2 P1 X797Y3

After you do that, can you run these commands and then return the output?


Also, in Edit->Device Settings, change the value of S Value Max to 1000. This is supposed to match the value of $30 in the GRBL configuration.

Good morning.
$H, homed.
[G54:797.000, 3.000, 0.000]
G55 through G59, all zeroes
G28, 30, 92, all zeroes.
[TLO: 0.000]
[PRB: 0.000, 0.000, 0.000]

<idle|wpos: -1194.000, -400.000, -3.000| FS:0,
0|WCO:797.000, 3.000, 0.000>

I changed the S value.