Nothing happens when I home my 2-axis laser

I have a laser engraver with only X and Y axis. When I click the “home” button the laser status changes to “Busy” and nothing happens, it just stays on busy.

I’ve wired my limit switches as normally closed. The machine works fine if I disable homing and limit switches but since I’ve installed them I would like to use them. Using the grbl status report i have verified that the limit switches change state when activated manually. In Lightburn’s Device Settings I have disabled the z-axis and I have tried all different combinations of GRBL settings but still no dice.

I know that grbl homes the Z-axis before the X and Y and I wonder if it is somehow waiting for the Z-axis limit signal before proceeding to the X and Y.

Any thoughts on how to resolve this is greatly appreciated.

Are you able to compile grbl under Arduino and flash your controller, its likely that homing is not enabled in the firmware, do you know what controller you have?

Thanks for the tip. I’ll give that a try shortly. I am using this no-name board from Amazon (it’s actually pretty nice)

Okay so I’ve updated GRBL to the latest version 1.1h and it has not fixed the problem. Here is a ss of my machine settings:

and here is a shot of my device settings:

This is what the machine looks like. It has the y-limit switch at the back end of the y-axis and the x-limit switch is on the left end of the x-axis:

Okay I fixed it!
I had to comment out two homing cycle lines in GRBL’s config.h (the lines with stars in front) and I uncommented the line indicated in red. I uploaded the code and homing now works!

Is it normal to have to do this to make homing work on a 2-axis (X, Y) machine? Are there ways to ignore the z-axis without modifying the firmware?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.